Pennock's Fiero Forum
  Technical Discussion & Questions
  I need some help here

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
I need some help here by Damorgan
Started on: 09-23-2013 05:18 AM
Replies: 13 (299 views)
Last post by: Damorgan on 09-27-2013 03:37 PM
Damorgan
Member
Posts: 93
From: Lexington, Tennessee. USA
Registered: Aug 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-23-2013 05:18 AM Click Here to See the Profile for DamorganClick Here to Email DamorganSend a Private Message to DamorganEdit/Delete MessageReply w/QuoteDirect Link to This Post
Ok so here is a picture of my engine bay (dirty I know but hey its a fiero)
This images is larger than 153600 bytes. Click to view.
The item circled at the top that is plugged with a lug nut, I have no idea what it is but I think it may have something to do with my crank case (PCV system) not entirely sure
Secondly I circled half of the tach filter...where in the world would the other half be located
and lastly the plug circled in green which plug is that? I may end up replacing both of the plugs but the clip is broken off of it and it causes the vehicle to die when it comes loose and if I get on it the fiero starts sputtering a bit (not as bad since I replaced my ignition coil though)
IP: Logged
PFF
System Bot
Gall757
Member
Posts: 10817
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 89
Rate this member

Report this Post09-23-2013 09:45 AM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
Does your temp gauge work?
IP: Logged
DaytonTD
Member
Posts: 175
From: Edmonton, Alberta, Canada
Registered: Dec 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-23-2013 11:25 AM Click Here to See the Profile for DaytonTDClick Here to Email DaytonTDSend a Private Message to DaytonTDEdit/Delete MessageReply w/QuoteDirect Link to This Post
I have no idea what that lug nut is covering, there shouldn't be anything there to cover. It may be the EGR tube bent that way and sticking up to plug it. I need a better pic to tell for sure of what it is actually plugging.

The tach filter should be located right below that wire somewhere, it may be missing entirely.

The plug in the green is the one that goes to the ignition module on the base of the distributer, the little cord is about 4 inch's long it is attached to, you can unplug it from both ends. It looks as if your coil is not even mounted, and if it is then it is mounted the wrong way. Your missing a little shield/platform it bolts to which screws into that y pipe. The distributer wire attached to it should be on the passenger side and the two connecters on it should be on the driver side. Not that it entirely matters but if that thing is loose right now it will defiantly contribute to intermittent problems with a bad connecter.
IP: Logged
84fiero123
Member
Posts: 29950
From: farmington, maine usa
Registered: Oct 2004


Feedback score: N/A
Leave feedback





Total ratings: 325
Rate this member

Report this Post09-23-2013 12:32 PM Click Here to See the Profile for 84fiero123Click Here to Email 84fiero123Send a Private Message to 84fiero123Edit/Delete MessageReply w/QuoteDirect Link to This Post
Napa got me new plugs with pigtails already in them, I just soldered the pigtails into the right wire and covered with liquid tape and electrical tape as well.

the thing with the lug nut I have no idea, there is nothing there on mine and I just took pictures to make sure, 86 Se as well.

will upload pictures if you want of mine.



Uploaded with ImageShack.us

Steve

------------------
Technology is great when it works,
and one big pain in the ass when it doesn't



Detroit iron rules all the rest are just toys.

[This message has been edited by 84fiero123 (edited 09-23-2013).]

IP: Logged
Damorgan
Member
Posts: 93
From: Lexington, Tennessee. USA
Registered: Aug 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-24-2013 05:21 AM Click Here to See the Profile for DamorganClick Here to Email DamorganSend a Private Message to DamorganEdit/Delete MessageReply w/QuoteDirect Link to This Post
My temp sensor does work Gall...

Dayton - Ill work on getting better pics for you soon to look at maybe tomorrow when its daylight lol, I cant find the tach filter wire whatsoever...where does the other end of the plug come from? Also the ignition coil is bolted down, I just replaced it and for some reason the one in it previously is exactly how I have it now...hmm may swap it around just because..

84 - Mine is a GT...is that what you mean?? Autozone had some new plugs that they offered me just wasnt sure how hard they are to change out. I think that the hose Im speaking of runs into the throttle body or somewhere near it but I am completely unsure I just am trying to find a picture of what that hose connects to...when I pull the throttlebody off to clean it maybe Ill find something there..

Thanks everyone for the help so far
IP: Logged
DaytonTD
Member
Posts: 175
From: Edmonton, Alberta, Canada
Registered: Dec 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-24-2013 10:19 AM Click Here to See the Profile for DaytonTDClick Here to Email DaytonTDSend a Private Message to DaytonTDEdit/Delete MessageReply w/QuoteDirect Link to This Post
See how this coil is mounted (second pic), that is what it should be like. The tach filter does not go anywhere, the wire you see goes to a 4 inch section then to a little cylinder, then back through the same wire.

Here is the tach filter:





This is the EGR tube, I have a feeling he disconnected it and flipped it back under the manifold to the otherside and plugged it off somehow, just check to see if your EGR tube is plugged in like this.

IP: Logged
Damorgan
Member
Posts: 93
From: Lexington, Tennessee. USA
Registered: Aug 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-25-2013 06:49 AM Click Here to See the Profile for DamorganClick Here to Email DamorganSend a Private Message to DamorganEdit/Delete MessageReply w/QuoteDirect Link to This Post
Ill look in the am, and are you getting good results out of that MSD coil? I kinda wanted to get one but didnt know if it was worth it and for the tach filter...so your saying it looks like I dont even have one orrr?
IP: Logged
n7vrz
Member
Posts: 521
From: Dixon Springs, TN
Registered: Dec 2010


Feedback score: (1)
Leave feedback

Rate this member

Report this Post09-25-2013 10:32 AM Click Here to See the Profile for n7vrzClick Here to Email n7vrzSend a Private Message to n7vrzEdit/Delete MessageReply w/QuoteDirect Link to This Post
I see your tach filter in the picture you put here. Right where it should be.
IP: Logged
DaytonTD
Member
Posts: 175
From: Edmonton, Alberta, Canada
Registered: Dec 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-25-2013 10:43 AM Click Here to See the Profile for DaytonTDClick Here to Email DaytonTDSend a Private Message to DaytonTDEdit/Delete MessageReply w/QuoteDirect Link to This Post
Those aren't my pictures but I do have an MSD coil. I personally don't really notice a difference between the Accel, MSD, and OEM coil.
IP: Logged
Damorgan
Member
Posts: 93
From: Lexington, Tennessee. USA
Registered: Aug 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-26-2013 05:55 AM Click Here to See the Profile for DamorganClick Here to Email DamorganSend a Private Message to DamorganEdit/Delete MessageReply w/QuoteDirect Link to This Post
What do you mean n7? My tach doesnt work at all soo...
IP: Logged
n7vrz
Member
Posts: 521
From: Dixon Springs, TN
Registered: Dec 2010


Feedback score: (1)
Leave feedback

Rate this member

Report this Post09-26-2013 11:14 AM Click Here to See the Profile for n7vrzClick Here to Email n7vrzSend a Private Message to n7vrzEdit/Delete MessageReply w/QuoteDirect Link to This Post
 
quote
Originally posted by Damorgan:

What do you mean n7? My tach doesnt work at all soo...


Just because your tach doesn't work doesn't mean the filter is missing. There are many reasons why the tach may not work. Broken wires, connector unplugged/not making contact, bad tach, etc.
But looking at the picture you posted I can see the tach filter.

IP: Logged
PFF
System Bot
n7vrz
Member
Posts: 521
From: Dixon Springs, TN
Registered: Dec 2010


Feedback score: (1)
Leave feedback

Rate this member

Report this Post09-26-2013 11:16 AM Click Here to See the Profile for n7vrzClick Here to Email n7vrzSend a Private Message to n7vrzEdit/Delete MessageReply w/QuoteDirect Link to This Post

n7vrz

521 posts
Member since Dec 2010
 
quote
Originally posted by Damorgan:

What do you mean n7? My tach doesnt work at all soo...


.

[This message has been edited by n7vrz (edited 09-26-2013).]

IP: Logged
n7vrz
Member
Posts: 521
From: Dixon Springs, TN
Registered: Dec 2010


Feedback score: (1)
Leave feedback

Rate this member

Report this Post09-26-2013 11:20 AM Click Here to See the Profile for n7vrzClick Here to Email n7vrzSend a Private Message to n7vrzEdit/Delete MessageReply w/QuoteDirect Link to This Post

n7vrz

521 posts
Member since Dec 2010
My error. I was looking at something close to where the filter should be. Then I re-read what you posted.
Again, my error. Sorry.
I'll go get a second cup of coffee and wake up.
IP: Logged
Damorgan
Member
Posts: 93
From: Lexington, Tennessee. USA
Registered: Aug 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-27-2013 03:37 PM Click Here to See the Profile for DamorganClick Here to Email DamorganSend a Private Message to DamorganEdit/Delete MessageReply w/QuoteDirect Link to This Post
lol its alright man so you think I should just buy a new tach filter and plug it to the connector and should be good to go on that??
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock