Pennock's Fiero Forum
  Technical Discussion & Questions
  I NEED HELP!! with an 84 Fiero/25th Anniversary Countach!!

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
I NEED HELP!! with an 84 Fiero/25th Anniversary Countach!! by dthami22
Started on: 11-06-2014 11:13 PM
Replies: 2 (144 views)
Last post by: 85 SE VIN 9 on 11-07-2014 07:12 AM
dthami22
Member
Posts: 40
From: Old Hickory
Registered: Jul 2014


Feedback score: N/A
Leave feedback

Rate this member

Report this Post11-06-2014 11:13 PM Click Here to See the Profile for dthami22Click Here to Email dthami22Send a Private Message to dthami22Edit/Delete MessageReply w/QuoteDirect Link to This Post
I have an awesome 25th Anniversary Kit Car Countach that I finished building this summer. I need some help with a few things and would really appreciate some advice and insight.

1. I am having fuel delivery problems. This is only on start up. The car runs great while driving and it starts up fine after it sits for a while. However, after running the engine it is very difficult to start within 30-60 minutes. I have to press down the pedal. I believe it is getting flooded and could be a leaking injector. How can I check to see if this is the cause? And how do I fix this? Or could it be something else?

2. When I turn on all controls in the cab it bogs down the electric and sometime the radio turns off. I am guessing this is a bad ground to the fuse box? If so, how can I can fix this? Or could it be something else? The lights also dim in and out along with the sub woofer bass.

3. The chassis started with a 2.5 iron duke and it was updated to the 2.8. The 1984 has different A/C compressor connections behind the drivers side cab in engine compartment. Where can I get the right hoses to fit the compressor on the 2.8? or where can I get an adapter to connect them? Does anybody know the exact sizes of the fittings from the compressor and the 1984 fittings coming from the front that are behind the driver in engine compartment?

Thanks to everybody who replies and if any of you know anybody on this forum that can help me please forward them this posting

THANKS!



[This message has been edited by dthami22 (edited 11-06-2014).]

IP: Logged
PFF
System Bot
countach711
Member
Posts: 796
From: Littleton, Colorado
Registered: Sep 2003


Feedback score: N/A
Leave feedback

Rate this member

Report this Post11-07-2014 01:45 AM Click Here to See the Profile for countach711Click Here to visit countach711's HomePageClick Here to Email countach711Send a Private Message to countach711Edit/Delete MessageReply w/QuoteDirect Link to This Post
I have an awesome 25th Anniversary Kit Car Countach that I finished building this summer. I need some help with a few things and would really appreciate some advice and insight.
Nice job, looks good! Congrates on finishing such a huge undertaking. I'm doing the same, any advice? Mine is taking years....
FYI this site has an excellent search function where you can find tons of great help. Be sure to check both active and archives.

1. I am having fuel delivery problems. This is only on start up. The car runs great while driving and it starts up fine after it sits for a while. However, after running the engine it is very difficult to start within 30-60 minutes. I have to press down the pedal. I believe it is getting flooded and could be a leaking injector. How can I check to see if this is the cause? And how do I fix this? Or could it be something else?

It might be the ignition module (or something like that.) They tend to have those symptoms when it goes bad. Most people carry a spare in the car.

2. When I turn on all controls in the cab it bogs down the electric and sometime the radio turns off. I am guessing this is a bad ground to the fuse box? If so, how can I can fix this? Or could it be something else? The lights also dim in and out along with the sub woofer bass.

You could add a second battery. Easier, add a bunch of new ground wires, and clean the existing ones. Find the post titled something like "Everyone with a V6 please read this" http://www.fiero.nl/forum/F.../HTML/043240-10.html

3. The chassis started with a 2.5 iron duke and it was updated to the 2.8. The 1984 has different A/C compressor connections behind the drivers side cab in engine compartment. Where can I get the right hoses to fit the compressor on the 2.8? or where can I get an adapter to connect them? Does anybody know the exact sizes of the fittings from the compressor and the 1984 fittings coming from the front that are behind the driver in engine compartment?
can't help with this one

Thanks to everybody who replies and if any of you know anybody on this forum that can help me please forward them this posting

THANKS! you're welcome for what it's worth!

[This message has been edited by countach711 (edited 11-07-2014).]

IP: Logged
85 SE VIN 9
Member
Posts: 690
From: Harwood Heights, IL, USA
Registered: Apr 2010


Feedback score: N/A
Leave feedback

Rate this member

Report this Post11-07-2014 07:12 AM Click Here to See the Profile for 85 SE VIN 9Click Here to Email 85 SE VIN 9Send a Private Message to 85 SE VIN 9Edit/Delete MessageReply w/QuoteDirect Link to This Post
Very nice!

The fuel problem might be vapor lock from the fuel line being too close to the exhaust or the engine.

The a/c issue was covered recently. You can get different length hoses made up. This was also in a thread this past summer. Just search for "a/c" and work your way through the many pages that come up.

If these are your only problems at this point you're in good shape!
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock