Pennock's Fiero Forum
  Technical Discussion & Questions
  3800sc issue

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
3800sc issue by My1stMidEng
Started on: 05-14-2014 07:14 AM
Replies: 0 (36 views)
Last post by: My1stMidEng on 05-14-2014 07:14 AM
My1stMidEng
Member
Posts: 253
From: Hampstead NH
Registered: Jul 2009


Feedback score: (1)
Leave feedback

Rate this member

Report this Post05-14-2014 07:14 AM Click Here to See the Profile for My1stMidEngClick Here to Email My1stMidEngSend a Private Message to My1stMidEngEdit/Delete MessageReply w/QuoteDirect Link to This Post
All,

I'm looking for suggestions on how to debug this new problem, or what might be wrong. The story might be a little long and confusing but I'll do my best to describe the series of events and symptoms.

Last season the blower belt would not stay on (some may remember this issue). I still suspect a blower issue but new spring tensioner and pulleys seems to have fixed this.
At the second to last event the rear tranny mount broke so I pulled the motor and welded the frame up.
At the last event I notice it ran badly at idle and a code was being thrown. At the time I could not read the code. I keep racing until it would no longer idle.
At home I find two problems: the first was the MAF had a broken pin likely from pulling the motor. The second was the MAP had unplugged itself. I think this happened during the day.

Fixed both problems. No codes being thrown,

It starts and idles but sounds like its missing on one cylinder now and then.
There's smoke coming from the rear side of the engine. Just like oil had spilled on the exhaust except I can't find any. No smoke coming from the exhaust.
If I punch-it it will rev to red-line but crappy.
(here's the strange part) If I slowly push the accelerator it will NOT accelerate. It sounds like it want to, gets rougher, but stays just off idle. I can push the pedal almost to the floor like this.

Pulled the plugs and they look fine.
No codes.

I'm worried that I may have a serous mechanical issue. Friday I'll be doing a leak-down test with a friend.

Any suggestions??

thanks
Frank


IP: Logged
PFF
System Bot



All times are ET (US)
next newest topic | next oldest topic

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock