Pennock's Fiero Forum
  Technical Discussion & Questions
  '88 Rear suspension (I think) Problem

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
'88 Rear suspension (I think) Problem by Egor
Started on: 07-17-2013 12:00 PM
Replies: 2 (191 views)
Last post by: Egor on 07-23-2013 02:01 PM
Egor
Member
Posts: 240
From: DALLAS area
Registered: Sep 2003


Feedback score: N/A
Leave feedback

Rate this member

Report this Post07-17-2013 12:00 PM Click Here to See the Profile for EgorSend a Private Message to EgorEdit/Delete MessageReply w/QuoteDirect Link to This Post
A few months ago, I began noticing a pull to the right of the steering at all speeds. I'd had a complete 4-wheel alignment done after an engine swap, and the car drove well until it started wanting to go right on me. I looked at the suspension several times, but never found anything unusual.

Today, I was jacking up the back end to check something unrelated when this bushing-like thing fell on the ground right next to the left rear wheel. I replaced the suspension with oly bushings when I did the engine swap, so I thought at first it might be a broken bushing because it has a kind of pinkish red color. But when I picked it up, it crumbled like old foam rubber.

Here is a picture:


The thing measures 30mm inside diameter and about 30mm thick counting parts broken off when I picked it up:






Any ideas of where this came from or why it affected the steering will be welcomed.
Thanks,
Egor


------------------
____________________________________________
"Of all the things I have lost during my lifetime, I miss
my mind the most."

IP: Logged
PFF
System Bot
Tom Slick
Member
Posts: 4326
From: Alvarado, TX
Registered: May 2003


Feedback score:    (24)
Leave feedback





Total ratings: 67
Rate this member

Report this Post07-17-2013 12:36 PM Click Here to See the Profile for Tom SlickClick Here to Email Tom SlickSend a Private Message to Tom SlickEdit/Delete MessageReply w/QuoteDirect Link to This Post
That looks like the bumpstop off of the strut.

Have you checked all nut and bolts for looseness?

The long lateral bolt usually gives the wayward feeling when loose.
IP: Logged
Egor
Member
Posts: 240
From: DALLAS area
Registered: Sep 2003


Feedback score: N/A
Leave feedback

Rate this member

Report this Post07-23-2013 02:01 PM Click Here to See the Profile for EgorSend a Private Message to EgorEdit/Delete MessageReply w/QuoteDirect Link to This Post
Tom, you were absolutely right.

I finally got to get the car in and jacked up this morning and found the other piece of the bump stop wedged up in the top.

Thanks,
Egor
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock