Pennock's Fiero Forum
  Technical Discussion & Questions
  Fiero frames (Page 2)

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version

This topic is 2 pages long:  1   2 
Previous Page | Next Page
next newest topic | next oldest topic
Fiero frames by bryantbackus
Started on: 02-24-2013 10:25 PM
Replies: 45 (2734 views)
Last post by: bryantbackus on 09-03-2013 10:07 PM
BV MotorSports
Member
Posts: 4808
From: Panama City, Fl
Registered: May 2001


Feedback score:    (7)
Leave feedback





Total ratings: 187
Rate this member

Report this Post06-20-2013 04:00 PM Click Here to See the Profile for BV MotorSportsClick Here to Email BV MotorSportsSend a Private Message to BV MotorSportsEdit/Delete MessageReply w/QuoteDirect Link to This Post
Doesn't look like you fixed the rust. Looks like you painted the rust. Did you atleast hit it with some naval jelly before you painted it?

IP: Logged
bryantbackus
Member
Posts: 52
From: hamden, ct,USA
Registered: Sep 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-20-2013 11:03 PM Click Here to See the Profile for bryantbackusClick Here to visit bryantbackus's HomePageClick Here to Email bryantbackusSend a Private Message to bryantbackusEdit/Delete MessageReply w/QuoteDirect Link to This Post
The bumpy spots i sanded down a little and cleaned them off. they were still bumpy but there wasn't any surface rust visible on the spots but the metal was bumpy in the spot.

Sorry I have been having trouble with some of my posts not appearing on my screen.

[This message has been edited by bryantbackus (edited 07-05-2013).]

IP: Logged
bryantbackus
Member
Posts: 52
From: hamden, ct,USA
Registered: Sep 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post07-05-2013 12:30 AM Click Here to See the Profile for bryantbackusClick Here to visit bryantbackus's HomePageClick Here to Email bryantbackusSend a Private Message to bryantbackusEdit/Delete MessageReply w/QuoteDirect Link to This Post
I took that picture before i fixed that spot anyway. i went back after i painted it to go over some other bad spots.

[This message has been edited by bryantbackus (edited 07-05-2013).]

IP: Logged
bryantbackus
Member
Posts: 52
From: hamden, ct,USA
Registered: Sep 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post07-05-2013 01:45 PM Click Here to See the Profile for bryantbackusClick Here to visit bryantbackus's HomePageClick Here to Email bryantbackusSend a Private Message to bryantbackusEdit/Delete MessageReply w/QuoteDirect Link to This Post
I removed the headlight assemblies from the the parts car and replaced the motors with the 2nd gen motors. I then bought the connectors from ebay because they were missing from my wire harness.
http://www.ebay.com/itm/280...id=p3984.m1439.l2649
the pictures i posted above have the two sets of cut wires. I'm wondering if the gray cut wire, and gray wire on the connector are supposed to match up. i didnt want to connect the wires wrong.
Also, i am searching for a lower radiator support, if anyone can help me get my hands on one i would appreciate it. Mine is rusted through. Thanks
IP: Logged
bryantbackus
Member
Posts: 52
From: hamden, ct,USA
Registered: Sep 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post07-07-2013 08:22 PM Click Here to See the Profile for bryantbackusClick Here to visit bryantbackus's HomePageClick Here to Email bryantbackusSend a Private Message to bryantbackusEdit/Delete MessageReply w/QuoteDirect Link to This Post
another question, i am having trouble removing the ac condenser from the parts car. do i absolutely need it in the car? If I left it out would i need to do anything else to the ac system?

[This message has been edited by bryantbackus (edited 03-18-2015).]

IP: Logged
bryantbackus
Member
Posts: 52
From: hamden, ct,USA
Registered: Sep 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-03-2013 10:07 PM Click Here to See the Profile for bryantbackusClick Here to visit bryantbackus's HomePageClick Here to Email bryantbackusSend a Private Message to bryantbackusEdit/Delete MessageReply w/QuoteDirect Link to This Post
Ok so it has been a while since i last posted and I've tried to get a lot done and i have read up a lot on other threads to learn what to do rather than post multiple questions that probably have an answer if i look hard enough.

Since my last post, I've installed the headlights,

and the radiator (which I don't have a picture of). I have decided to not use the condenser for now, I will go back at a later date and do that. I am more worried about getting the car running.

I also fabricated a front impact bar as both of mine were rusted up. this picture is before it was welded up. I don't have an after picture yet.


I then took the shifter and brake/ clutch pedal assembly out of the parts car. i soaked them in a de-ruster then sprayed the shifter with a clear coat of an anti rust protective spray. Then i greased it up and bolted in the project car. I also used frame paint and the clear coat on the brake/ clutch pedal and greased that up too. then i installed it in the project car along with the steering column from the parts car.



I had a cradle sitting around and so I got it down to the bare metal first, then giving it a couple coats of rubberized undercoating, before giving it a red coat of high temp enamel paint.



I have bought stainless steel clutch and brake lines from the fiero store as well as some braided brake hoses and I still need to install those


Today my new engine came and i needed my junk engine as a core so i have to cut off the cradle after disconnecting everything due to seized cradle bolts.
old engine

I have since removed all brackets and anything needed for the swap (I am using a 3.4 from a firebird) all that is left on the cradle is transmission and axles.

New engine my step dad has a friend at Chuck and Eddies so i got a good deal on this engine which is fairly complete.

I am going to be making the switch to dis since i have all the components. I plan on getting EBL P4 Flash using the 7730 ecm and when get, that i will repin the connectors.
I plan on replacing the suspension bushings with poly with a total poly pack from the fierostore and the cradle busings with poly as well. At the same time i will clean and recondition all the suspension parts, and replace the shocks and struts. Then i will work more on setting up the cradle for the engine as well as switching parts on to the 3.4. i plan on cleaning the engine and painting it.
Any advice, comments, critiques, or tips are welcomed

[This message has been edited by bryantbackus (edited 09-03-2013).]

IP: Logged
Previous Page | Next Page

This topic is 2 pages long:  1   2 
next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock