Pennock's Fiero Forum
  Technical Discussion & Questions
  No inside blower motor fan working

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
No inside blower motor fan working by 72and86
Started on: 06-13-2020 11:30 AM
Replies: 7 (122 views)
Last post by: 72and86 on 06-14-2020 07:32 PM
72and86
Member
Posts: 16
From: Vernon CT
Registered: Aug 2016


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-13-2020 11:30 AM Click Here to See the Profile for 72and86Click Here to Email 72and86Send a Private Message to 72and86Edit/Delete MessageReply w/QuoteDirect Link to This Post
Still going through my project 1986 SE car.
I get no internal fan (blower motor) on any climate section option. No fan on ANY speed. I hear the buzz of the routing of where the air should be directed but NO air. Fuse checks out.
Also:
I hear the AC try to engage and engine decrease in RPM but the compressor doesn't come on. (may be out of R12).

So no fan on anything . any speed.
Where do i start? Thanks guys.
IP: Logged
PFF
System Bot
imacflier
Member
Posts: 868
From: Levittown, NY, USA
Registered: Apr 2002


Feedback score: (1)
Leave feedback

Rate this member

Report this Post06-13-2020 12:16 PM Click Here to See the Profile for imacflierClick Here to Email imacflierSend a Private Message to imacflierEdit/Delete MessageReply w/QuoteDirect Link to This Post
From the '88 FSM:

1. Check Htr/AC fuse
2. Ignition switch in run, does blower operate in at any speed setting?
3. If NOP, then disconnect blower connection, set blower speed on HI
4. Check PPL wire to ground and PPL wire to BLACK, both should show battery voltage.
5. if either open trace for open wire.
6. If good, replace blower motor.

I do not know if it is identical for the '86. You really should get an FSM.

Good luck,

Larry
IP: Logged
Dennis LaGrua
Member
Posts: 13497
From: Hillsborough, NJ U.S.A.
Registered: May 2000


Feedback score:    (13)
Leave feedback





Total ratings: 320
Rate this member

Report this Post06-13-2020 12:53 PM Click Here to See the Profile for Dennis LaGruaClick Here to Email Dennis LaGruaSend a Private Message to Dennis LaGruaEdit/Delete MessageReply w/QuoteDirect Link to This Post
Put A/C on. Then go to the engine blower connector and see if you can read voltage there with a volt/ohm meter or even a test lamp. Check if voltage is there. If it is its the blower motor or the connector. If not check the blower motor relay.

------------------
" THE BLACK PARALYZER" -87GT 3800SC Series III engine, custom ZZP /Frozen Boost Intercooler setup, 3.4" Pulley, Northstar TB, LS1 MAF, 3" Spintech/Hedman Exhaust, P-log Manifold, Autolite 104's, MSD wires, Custom CAI, 4T65eHD w. custom axles, Champion Radiator, S10 Brake Booster, HP Tuners VCM Suite.
"THE COLUSSUS"
87GT - ALL OUT 3.4L Turbocharged engine, Garrett Hybrid Turbo, MSD ign., modified TH125H
" ON THE LOOSE WITHOUT THE JUICE "

IP: Logged
theogre
Member
Posts: 29201
From: USA
Registered: Mar 99


Feedback score: N/A
Leave feedback





Total ratings: 549
Rate this member

Report this Post06-13-2020 01:08 PM Click Here to See the Profile for theogreClick Here to visit theogre's HomePageSend a Private Message to theogreEdit/Delete MessageReply w/QuoteDirect Link to This Post
First Pull blower motor and look at it and inside the "box."
Clean as needed.
See http://www.fiero.nl/forum/Forum2/HTML/141959.html or search blower resistor fire.

Then While keeping fingers etc from hitting the wheel... connect ground to motor case. Quick pulse Plus term to battery.
Wheel may not hurt you but it can break fairly easy.

Then Carefully follow the rest of trying to find problem(s).
⚠️ The Resistors can/will get Red Hot and Fast w/o air flow to cool them. So first select only High Speed to find issues w/ a "dead" motor.

Blower Switch and Relay controls the blower mostly.
Button board is only thing to shut off the blower and normally Only when Off Button is Depressed.
If the board has issues then could kill power to the switch BUT Blower has 2 Relays...
1 is relay to run the whole system... If that gets power to run AC compressor then board and 1st relay are good and blower should be on if the blower switch etc is good.
2 is High Speed blower that's bypassing blower power out of htr ac fuse/breaker control. Relay Contacts get power directly from FL A as most of the rest of car but W/O any smaller fuse.

Both relays are in the front next to Acc/drier.

------------------
Dr. Ian Malcolm: Yeah, but your scientists were so preoccupied with whether or not they could, they didn't stop to think if they should.
(Jurassic Park)


The Ogre's Fiero Cave

IP: Logged
DukeHog
Member
Posts: 18
From: North Carolina
Registered: Feb 2019


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-13-2020 05:05 PM Click Here to See the Profile for DukeHogSend a Private Message to DukeHogEdit/Delete MessageReply w/QuoteDirect Link to This Post
Same happened to me a few months ago. Bad relay.
IP: Logged
72and86
Member
Posts: 16
From: Vernon CT
Registered: Aug 2016


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-14-2020 01:37 PM Click Here to See the Profile for 72and86Click Here to Email 72and86Send a Private Message to 72and86Edit/Delete MessageReply w/QuoteDirect Link to This Post
 
quote
Originally posted by DukeHog:

Same happened to me a few months ago. Bad relay.


BOTH of them?
IP: Logged
DukeHog
Member
Posts: 18
From: North Carolina
Registered: Feb 2019


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-14-2020 04:28 PM Click Here to See the Profile for DukeHogSend a Private Message to DukeHogEdit/Delete MessageReply w/QuoteDirect Link to This Post
The relay I replaced was on the front firewall near the blower motor. In my case if I squeezed the relay with two fingers I could feel a click and the fan would come on. It would click off again when I released it.
IP: Logged
72and86
Member
Posts: 16
From: Vernon CT
Registered: Aug 2016


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-14-2020 07:32 PM Click Here to See the Profile for 72and86Click Here to Email 72and86Send a Private Message to 72and86Edit/Delete MessageReply w/QuoteDirect Link to This Post
Fixed.
The blower was getting power. But it wasn't turning. we removed it from the car, put it on another car battery and it blew like mad. We replaced the unit and made a better ground and now it works. It wasn't the relays or the BM. Maybe it just needed waking up. Solved,
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock