Pennock's Fiero Forum
  Technical Discussion & Questions
  Changing in column wiper switch....I'm stuck!

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Changing in column wiper switch....I'm stuck! by Monkeyman
Started on: 07-20-2015 07:41 PM
Replies: 4 (136 views)
Last post by: Monkeyman on 07-21-2015 02:16 AM
Monkeyman
Member
Posts: 15617
From: N. Wilkesboro, NC, USA
Registered: Nov 1999


Feedback score: (5)
Leave feedback





Total ratings: 182
Rate this member

Report this Post07-20-2015 07:41 PM Click Here to See the Profile for MonkeymanSend a Private Message to MonkeymanEdit/Delete MessageReply w/QuoteDirect Link to This Post
I'm in the process of changing my in column wiper switch (NOT the stalk but the part the stalk plugs into). I've got everything removed down to the round turn signal device (in the column). Not sure where to go from here. I'd like to get this finished tonight, if possible, so any suggestions would be greatly appreciated.

Here's where I'm at right now. The part I circled is the part I'm trying to swap out.

This images is larger than 153600 bytes. Click to view.

[This message has been edited by Monkeyman (edited 07-20-2015).]

IP: Logged
PFF
System Bot
seajai
Member
Posts: 1534
From: Circle Pines, Minnesota
Registered: Feb 2012


Feedback score:    (42)
Leave feedback





Total ratings: 52
Rate this member

Report this Post07-20-2015 08:15 PM Click Here to See the Profile for seajaiSend a Private Message to seajaiEdit/Delete MessageReply w/QuoteDirect Link to This Post
You need to remove the lock housing (the 3 silver bolts) to remove the wiper switch.
IP: Logged
Monkeyman
Member
Posts: 15617
From: N. Wilkesboro, NC, USA
Registered: Nov 1999


Feedback score: (5)
Leave feedback





Total ratings: 182
Rate this member

Report this Post07-20-2015 08:21 PM Click Here to See the Profile for MonkeymanSend a Private Message to MonkeymanEdit/Delete MessageReply w/QuoteDirect Link to This Post
Done. Now the high beam doohickey popped out. I knew it was temperamental but it still happened. Gotta figure out how to put that back then I can reassemble and (God willing) the wipers will work. It'll sure feel like an accomplishment if I can get 'er done!
IP: Logged
Monkeyman
Member
Posts: 15617
From: N. Wilkesboro, NC, USA
Registered: Nov 1999


Feedback score: (5)
Leave feedback





Total ratings: 182
Rate this member

Report this Post07-20-2015 10:11 PM Click Here to See the Profile for MonkeymanSend a Private Message to MonkeymanEdit/Delete MessageReply w/QuoteDirect Link to This Post
Mostly back together. There must be some trick to getting that high beam follower back in place. I probably worked at it for an hour.

What's the purpose of the plastic cover between the lock plate and the steering wheel? Is it just cosmetic to fill the gap between the 2? I couldn't get that to snap back in place so I left it out.

The yellow (was probably white when new) horn ring under the lock plate had the sticking out part (it's a technical term) broken off. I could see some sort of epoxy so it had been fixed before. Does someone sell this part? I don't know the name so I can't google it.

I still need to put the gauges back in place and tidy up the wiring. I'll do that when it cools down a bit then hook up the battery and see if the wipers work. If they work, I'll finish installing the stereo.
IP: Logged
Monkeyman
Member
Posts: 15617
From: N. Wilkesboro, NC, USA
Registered: Nov 1999


Feedback score: (5)
Leave feedback





Total ratings: 182
Rate this member

Report this Post07-21-2015 02:16 AM Click Here to See the Profile for MonkeymanSend a Private Message to MonkeymanEdit/Delete MessageReply w/QuoteDirect Link to This Post
Wiper switch replaced and STILL NO WIPERS!!! The only improvement is a lack of phantom wipe on start. I've replaced the fuse (assuming it's the 30 amp at the very bottom of the fuse block). I'm NOT getting back into the column. Everything's plugged in as it should be. The PO allegedly replaced the wiper board. I have no idea where to go from here.

I've sweated myself into 2 showers tonight, my head hurts, I got something in my eye and I still can't drive the damn car. The battery's dead from the amp staying on (which is now on my kitchen counter and for sale) and I can't even drive the car around to charge up the battery. All I can do is park it back on the street and let it sit until it's sold. I was really hoping I could fix this and start to enjoy it again but I'm so turned off by the car (and at this point, Fieros in general) that I'd be happy never to see it again.

If anybody has any suggestions, I'd really appreciate them.

EDIT: Just ordered a pulse wiper board from RockAuto. It should be here Thursday. I'm off Friday so I'll install it then. (Bastard better work.)

[This message has been edited by Monkeyman (edited 07-21-2015).]

IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock