Pennock's Fiero Forum
  Technical Discussion & Questions
  Turn signal help

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Turn signal help by bryantbackus
Started on: 06-21-2015 01:13 PM
Replies: 1 (65 views)
Last post by: 84fiero123 on 06-21-2015 01:28 PM
bryantbackus
Member
Posts: 52
From: hamden, ct,USA
Registered: Sep 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-21-2015 01:13 PM Click Here to See the Profile for bryantbackusClick Here to visit bryantbackus's HomePageClick Here to Email bryantbackusSend a Private Message to bryantbackusEdit/Delete MessageReply w/QuoteDirect Link to This Post
So I had been having problems with my turn signals, they would blink on one side and stay lit on the other. First I replaced the flasher module under the dash but after doing that, neither side will blink or either light up on the instrument panel. I truee putting the old flasher back but nothing would happen. I checked the wiring on the bulb that stayed lit and turned out it was wired wrong. I fixed the wiring but the turn signals still won't flash left or right or even come on. The hazards still worked all the while. I checked the fuses which seem to be okay and the hazards working led me to believe that the wiring to the lights are okay as well. I decided I would try to replace the turn signal switch itself. In order to do so without removing the column from the car, I unpinned the switch connector to get it through the harness protector in the columnn then re pinned it before connecting it. I used the old connector as reference since the wires were the same color but looking back Im not sure if it's 100% all in the right place, but I'm pretty sure. I used "Illustrated tilt steering column disassembly" by Oliver Scholz to take the column apart and put it back together. Now the problem in having is that when I turn the turn signal stalk to the left turn position, the horn sounds and does nothing in the right turn position. Also, when I press the hazard switch, the horn beeps as if it were the turn signal lights blinking. Do you think it could be a problem at the connector, in the column at the switch or anywhere else?
Thanks
IP: Logged
PFF
System Bot
84fiero123
Member
Posts: 29950
From: farmington, maine usa
Registered: Oct 2004


Feedback score: N/A
Leave feedback





Total ratings: 325
Rate this member

Report this Post06-21-2015 01:28 PM Click Here to See the Profile for 84fiero123Click Here to Email 84fiero123Send a Private Message to 84fiero123Edit/Delete MessageReply w/QuoteDirect Link to This Post
Replace the entire switch, you screwed up something on this one. Pulling the wheel only takes a few min and a couple of tools you can borrow from the parts store. Just leave them a deposit and you get it all back when you return it. You don't Have to pull the entire column to do it, I just run a peace of hard wire up threw the column, I have seen people use string as well, but they tie it to the bottom of the old wire before pulling it up threw, then tie it to the new wire up top and pull it back down threw.

Steve

------------------
Technology is great when it works,
and one big pain in the ass when it doesn't



Detroit iron rules all the rest are just toys.

[This message has been edited by 84fiero123 (edited 06-21-2015).]

IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock