Pennock's Fiero Forum
  Technical Discussion & Questions
  86 died need help

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
86 died need help by fireojay86
Started on: 04-05-2015 08:19 PM
Replies: 12 (143 views)
Last post by: 2.5 on 04-08-2015 03:59 PM
fireojay86
Member
Posts: 82
From: COON RAPIDS
Registered: Apr 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post04-05-2015 08:19 PM Click Here to See the Profile for fireojay86Click Here to Email fireojay86Send a Private Message to fireojay86Edit/Delete MessageReply w/QuoteDirect Link to This Post
Last night my 86 se 2.8 died. ame arund a corner and as I accelerated it died just cut out. This happen to me a week ago to changed out the ICM but I take that was not it. This time when it happened I did notice that the fuel pump was still running and when I tried to crank it over I had smoke comming from the tail pipe. I finally got it going but had to put it to the floor to get it going. once it was running I reved it a few time it clear out and i drove it for about five miles with no problems and no smoke. started right back up and still no smoke. Can anyone help me in the right direction.

I have replaced in the last 4000 miles
IAC
ICM
Coil
plug and wires
Distributor
o2 sensor

After I replaced the ICM it was running fine the poof it dies again four days later
IP: Logged
PFF
System Bot
Csjag
Member
Posts: 3170
From: Ocklawaha,Fl, USA
Registered: Dec 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post04-05-2015 08:21 PM Click Here to See the Profile for CsjagClick Here to Email CsjagSend a Private Message to CsjagEdit/Delete MessageReply w/QuoteDirect Link to This Post
Fuel pumps sometimes do this when they are going bad
IP: Logged
Gall757
Member
Posts: 10622
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 88
Rate this member

Report this Post04-05-2015 08:28 PM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
New components are not necessarily good components. Some ICMs have a very short life....and be sure to clean connector pins and check wires.
IP: Logged
fireojay86
Member
Posts: 82
From: COON RAPIDS
Registered: Apr 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post04-05-2015 08:40 PM Click Here to See the Profile for fireojay86Click Here to Email fireojay86Send a Private Message to fireojay86Edit/Delete MessageReply w/QuoteDirect Link to This Post
did it when I replaced distributor with a new icm in it. Changed back to the original icm and problem went away. Back then it would die but start right back up. This time I would have to work at it to get it started.
IP: Logged
fireojay86
Member
Posts: 82
From: COON RAPIDS
Registered: Apr 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post04-06-2015 08:53 PM Click Here to See the Profile for fireojay86Click Here to Email fireojay86Send a Private Message to fireojay86Edit/Delete MessageReply w/QuoteDirect Link to This Post
please help
IP: Logged
Gall757
Member
Posts: 10622
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 88
Rate this member

Report this Post04-07-2015 03:06 PM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
Have you re-tested your new ICM?
IP: Logged
jaskispyder
Member
Posts: 21510
From: Northern MI
Registered: Jun 2002


Feedback score:    (22)
Leave feedback





Total ratings: 205
Rate this member

Report this Post04-07-2015 03:41 PM Click Here to See the Profile for jaskispyderSend a Private Message to jaskispyderEdit/Delete MessageReply w/QuoteDirect Link to This Post
Did you use heat sink compound under the ICM?

Check engine light on?

Does it just act like it shut off, or does it sputter? When it dies, pull the cap off the valve for the fuel line and see if you have gas squirting out (after priming the pump by turning on the key, or powering the fuel pump at the ALDL).
IP: Logged
fireojay86
Member
Posts: 82
From: COON RAPIDS
Registered: Apr 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post04-08-2015 12:49 PM Click Here to See the Profile for fireojay86Click Here to Email fireojay86Send a Private Message to fireojay86Edit/Delete MessageReply w/QuoteDirect Link to This Post
It just dies, yes to the stuff under the ICM. JUst started it agian this morning and it started right up the died after a min. Took alittle to start up but once again the fuel pump continued to run after the car died.
IP: Logged
jaskispyder
Member
Posts: 21510
From: Northern MI
Registered: Jun 2002


Feedback score:    (22)
Leave feedback





Total ratings: 205
Rate this member

Report this Post04-08-2015 01:01 PM Click Here to See the Profile for jaskispyderSend a Private Message to jaskispyderEdit/Delete MessageReply w/QuoteDirect Link to This Post
get a gauge on that fuel line to see the pressure.

Have the ICM tested.

Do you have spark after it dies?
IP: Logged
2.5
Member
Posts: 40898
From: Southern MN
Registered: May 2007


Feedback score: (1)
Leave feedback





Total ratings: 178
Rate this member

Report this Post04-08-2015 01:37 PM Click Here to See the Profile for 2.5Send a Private Message to 2.5Edit/Delete MessageReply w/QuoteDirect Link to This Post
You mentioned you replaced the coil.
Did you also replace the pick up coil?
IP: Logged
fireojay86
Member
Posts: 82
From: COON RAPIDS
Registered: Apr 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post04-08-2015 02:18 PM Click Here to See the Profile for fireojay86Click Here to Email fireojay86Send a Private Message to fireojay86Edit/Delete MessageReply w/QuoteDirect Link to This Post
New Distributor, New coil. It has happened on two different ICM
IP: Logged
PFF
System Bot
jaskispyder
Member
Posts: 21510
From: Northern MI
Registered: Jun 2002


Feedback score:    (22)
Leave feedback





Total ratings: 205
Rate this member

Report this Post04-08-2015 02:31 PM Click Here to See the Profile for jaskispyderSend a Private Message to jaskispyderEdit/Delete MessageReply w/QuoteDirect Link to This Post
 
quote
Originally posted by fireojay86:

New Distributor, New coil. It has happened on two different ICM


Comes down to three things... air, spark, fuel.

Check for a spark (they sell an inline tool that gives you a visual indication - like a timing light), and if you have spark, spray some starting fluid into the TBI to see if it will fire up.

IP: Logged
2.5
Member
Posts: 40898
From: Southern MN
Registered: May 2007


Feedback score: (1)
Leave feedback





Total ratings: 178
Rate this member

Report this Post04-08-2015 03:59 PM Click Here to See the Profile for 2.5Send a Private Message to 2.5Edit/Delete MessageReply w/QuoteDirect Link to This Post
So maybe too much fuel then? Alot of people talk about a cold start injector sticking maybe that? Could check fuel pressure.
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock