Pennock's Fiero Forum
  Technical Discussion & Questions
  ICM and injectors

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
ICM and injectors by Harley95
Started on: 03-17-2015 07:42 AM
Replies: 4 (106 views)
Last post by: Harley95 on 03-17-2015 10:20 AM
Harley95
Member
Posts: 135
From: Kentucky
Registered: Jul 2014


Feedback score: N/A
Leave feedback

Rate this member

Report this Post03-17-2015 07:42 AM Click Here to See the Profile for Harley95Click Here to Email Harley95Send a Private Message to Harley95Edit/Delete MessageReply w/QuoteDirect Link to This Post
I just have a quick question on the ICM and MAP sensor, could the ICM prevent some of my injectors from firing or would a bad ICM only affect all of them at once. I was also wondering what the symptoms of a bad MAP sensor are. and one last question what could keep causing my injectors to stop functioning?

[This message has been edited by Harley95 (edited 03-17-2015).]

IP: Logged
PFF
System Bot
Gall757
Member
Posts: 10661
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 88
Rate this member

Report this Post03-17-2015 08:07 AM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
The injectors fire when the ECM completes the circuit to ground. The ECM gets the signal to do that from the ICM. There are 2 circuits....INJ1 and INJ2....each with their own fuse. If the ground wire is bad at the ECM, things don't go well, but you can also loose the signal anywhere along that circuit, including the injector. If they have been sitting for a few years they are often 'sticky'. The ICM often fails completely and turns the engine off, but it can also fail in other strange ways, so it is always a suspect.
IP: Logged
Harley95
Member
Posts: 135
From: Kentucky
Registered: Jul 2014


Feedback score: N/A
Leave feedback

Rate this member

Report this Post03-17-2015 08:36 AM Click Here to See the Profile for Harley95Click Here to Email Harley95Send a Private Message to Harley95Edit/Delete MessageReply w/QuoteDirect Link to This Post
thanks Gall, these injectors are only about 3 months old so I don't know what would be killing them.
IP: Logged
Gall757
Member
Posts: 10661
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 88
Rate this member

Report this Post03-17-2015 09:59 AM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
As for the MAP sensor..... the computer has a 'default', that it runs if the MAP is disconnected, so if you unplug the MAP and the engine runs better, there is something wrong with your MAP sensor. Check around it for loose vacuum lines too. I had one little line that was not on straight, and the car sounded awful.
IP: Logged
Harley95
Member
Posts: 135
From: Kentucky
Registered: Jul 2014


Feedback score: N/A
Leave feedback

Rate this member

Report this Post03-17-2015 10:20 AM Click Here to See the Profile for Harley95Click Here to Email Harley95Send a Private Message to Harley95Edit/Delete MessageReply w/QuoteDirect Link to This Post
it somewhat seems to run a little better with it unplugged but immediately stalls out if put in gear with the MAP unplugged. I can hear a loud leak from somewhere but cannot find it.
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock