Pennock's Fiero Forum
  Technical Discussion & Questions
  fuel pump won't stop running !

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
fuel pump won't stop running ! by Lou6t4gto
Started on: 03-12-2015 10:22 AM
Replies: 3 (99 views)
Last post by: Shho13 on 03-17-2015 01:44 PM
Lou6t4gto
Member
Posts: 8436
From: sarasota
Registered: May 2008


Feedback score:    (7)
Leave feedback

Rate this member

Report this Post03-12-2015 10:22 AM Click Here to See the Profile for Lou6t4gtoClick Here to Email Lou6t4gtoSend a Private Message to Lou6t4gtoEdit/Delete MessageReply w/QuoteDirect Link to This Post
A friend stopped over yesterday with a 1986 GT 2.8 stick. The fuel pump starts running when key is turned on, And Does NOT shut off at all. Fuel pump "sender" ?? What else to check ? Thanks
IP: Logged
PFF
System Bot
olejoedad
Member
Posts: 14421
From: Clarendon Twp., MI
Registered: May 2004


Feedback score: (5)
Leave feedback





Total ratings: 192
Rate this member

Report this Post03-12-2015 10:30 AM Click Here to See the Profile for olejoedadClick Here to Email olejoedadSend a Private Message to olejoedadEdit/Delete MessageReply w/QuoteDirect Link to This Post
Stuck relay or oil pressure sender.
Unplug one or the other, see which one it is.
IP: Logged
Puglet01
Member
Posts: 153
From: Smithton PA
Registered: Jan 2008


Feedback score: N/A
Leave feedback

Rate this member

Report this Post03-16-2015 12:30 PM Click Here to See the Profile for Puglet01Send a Private Message to Puglet01Edit/Delete MessageReply w/QuoteDirect Link to This Post
On mine it was the oil pressure sending unit but my fuel pump ran all the time till the battery died.
IP: Logged
Shho13
Member
Posts: 865
From: North Jersey
Registered: Feb 2014


Feedback score: (5)
Leave feedback

Rate this member

Report this Post03-17-2015 01:44 PM Click Here to See the Profile for Shho13Click Here to Email Shho13Send a Private Message to Shho13Edit/Delete MessageReply w/QuoteDirect Link to This Post
Usually shorts through the oil pressure sending unit... unplug that first and see what happens, then if no luck check the relay.

If it's the sending unit, just replace it with a new one. Look up how to modify your car to accept the 1988 version of the sending unit, its simple to do. They are much more reliable and a lot less expensive.


Edit: Here is the link to the modification if you choose to do it!
------------------
"Discord"
Red 1988 GT under restoration!

( ͡° ͜ʖ ͡°)

[This message has been edited by Shho13 (edited 03-17-2015).]

IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock