Pennock's Fiero Forum
  Technical Discussion & Questions
  Now my 2.8 wont even start

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Now my 2.8 wont even start by Fier-oh41229
Started on: 12-30-2014 05:49 PM
Replies: 0 (97 views)
Last post by: Fier-oh41229 on 12-30-2014 05:49 PM
Fier-oh41229
Member
Posts: 141
From: Niagara Falls NY
Registered: Dec 2012


Feedback score: (1)
Leave feedback

Rate this member

Report this Post12-30-2014 05:49 PM Click Here to See the Profile for Fier-oh41229Send a Private Message to Fier-oh41229Edit/Delete MessageReply w/QuoteDirect Link to This Post
When i got the car it was starting and running rough with a high idle that was surging between 500rpm and 2000rpm glowing exhaust headers and a broken egr valve. I replaced the egr valve then found out that the ground wire had snapped. I replaced the ground and even added a second one. At this point the engine was still starting and running quite rough but the idle wasn't fluctuating. I was told the glowing exhaust was the oxygen sensor. Replaced that and it started up and ran (still rough) after a few tries where it started and died then started and died. The exhaust wasn't glowing anymore but the idle was steady around 2k rpm. I let it run for about 15 mins then shut it off. I tried to start it again about 5 mins later and it cranked over but would not start! Today i tried to start it again and it started very quickly and died about 5 times. We never really got it idling on its own but we were able to listen to it run for about 2 seconds at a time before it kept dying. Sounded pretty rough. Any ideas?
IP: Logged
PFF
System Bot



All times are ET (US)
next newest topic | next oldest topic

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock