Pennock's Fiero Forum
  Technical Discussion & Questions
  2.8 Exhaust manifold glowing orange

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
2.8 Exhaust manifold glowing orange by Fier-oh41229
Started on: 12-26-2014 06:06 PM
Replies: 6 (311 views)
Last post by: bobace455 on 12-28-2014 02:48 PM
Fier-oh41229
Member
Posts: 141
From: Niagara Falls NY
Registered: Dec 2012


Feedback score: (1)
Leave feedback

Rate this member

Report this Post12-26-2014 06:06 PM Click Here to See the Profile for Fier-oh41229Send a Private Message to Fier-oh41229Edit/Delete MessageReply w/QuoteDirect Link to This Post
When i got the car (88 formula) the idle fluctuated quite a lot the egr needed replacing and the exhaust manifold would glow. I replaced the egr tube and valve replaced my ground wire (as well as added a second one) and now it idles fine but it still glows orange and i cant figure out why. My thought is its because a sensor is getting a wrong reading? Maybe because it went bad or a vacuum line has a leak and its causing it to run lean? Any ideas? Thanks - Dave
IP: Logged
PFF
System Bot
mcguiver3
Member
Posts: 742
From: Beacon Falls, CT, USA
Registered: Jan 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-26-2014 08:44 PM Click Here to See the Profile for mcguiver3Send a Private Message to mcguiver3Edit/Delete MessageReply w/QuoteDirect Link to This Post
Definitely a lean condition.
Many causes, more than likely a major vacuum leak.
Or clogged injectors.
IP: Logged
mcguiver3
Member
Posts: 742
From: Beacon Falls, CT, USA
Registered: Jan 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-26-2014 08:46 PM Click Here to See the Profile for mcguiver3Send a Private Message to mcguiver3Edit/Delete MessageReply w/QuoteDirect Link to This Post

mcguiver3

742 posts
Member since Jan 2012
Try spraying some carb cleaner around and see if the idle picks up.
There is your leak.
IP: Logged
88FieroGT TTops
Member
Posts: 700
From: Woodbridge,Va USA
Registered: Mar 2012


Feedback score: (4)
Leave feedback

Rate this member

Report this Post12-26-2014 09:40 PM Click Here to See the Profile for 88FieroGT TTopsClick Here to Email 88FieroGT TTopsSend a Private Message to 88FieroGT TTopsEdit/Delete MessageReply w/QuoteDirect Link to This Post
I had the same--O2 sensor.

------------------
Pat Jones

IP: Logged
Fier-oh41229
Member
Posts: 141
From: Niagara Falls NY
Registered: Dec 2012


Feedback score: (1)
Leave feedback

Rate this member

Report this Post12-28-2014 11:18 AM Click Here to See the Profile for Fier-oh41229Send a Private Message to Fier-oh41229Edit/Delete MessageReply w/QuoteDirect Link to This Post
Thanks! It was the oxygen sensor. Exhaust looks normal. But now it has a high idle around 2k. Any ideas?
IP: Logged
Fier-oh41229
Member
Posts: 141
From: Niagara Falls NY
Registered: Dec 2012


Feedback score: (1)
Leave feedback

Rate this member

Report this Post12-28-2014 11:51 AM Click Here to See the Profile for Fier-oh41229Send a Private Message to Fier-oh41229Edit/Delete MessageReply w/QuoteDirect Link to This Post
And now it won't start. ????
IP: Logged
bobace455
Member
Posts: 65
From: Cedar Falls, IA, USA
Registered: Dec 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-28-2014 02:48 PM Click Here to See the Profile for bobace455Send a Private Message to bobace455Edit/Delete MessageReply w/QuoteDirect Link to This Post
Burnt/leaking exhaust valve will cause red exhaust manifold. Try to pinpoint the cylinder that it glows red around and do a compression test - it should show up there.
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock