Pennock's Fiero Forum
  Technical Discussion & Questions
  Rough idle after warm up 88 Duke

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Rough idle after warm up 88 Duke by un fiero
Started on: 09-16-2014 09:34 PM
Replies: 5 (145 views)
Last post by: phonedawgz on 09-22-2014 01:10 PM
un fiero
Member
Posts: 71
From: Houston, Texas, USA
Registered: Jun 2014


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-16-2014 09:34 PM Click Here to See the Profile for un fieroClick Here to Email un fieroSend a Private Message to un fieroEdit/Delete MessageReply w/QuoteDirect Link to This Post
My 88 base coupe 2.5 duke is running great (mostly), but 50% of the time it idles low after warm up. I did a head gasket a couple months ago as well as injector o-ring, thermostat, intake temp sensor, egr valve and numerous vac hoses both coolant temp sensors and the ICM. It starts and runs great except for when it starts this idle dipping. It doesn't stall but feels like it wants to. Any suggestions? Thanks!
IP: Logged
PFF
System Bot
2.5
Member
Posts: 40903
From: Southern MN
Registered: May 2007


Feedback score: (1)
Leave feedback





Total ratings: 178
Rate this member

Report this Post09-17-2014 09:09 AM Click Here to See the Profile for 2.5Send a Private Message to 2.5Edit/Delete MessageReply w/QuoteDirect Link to This Post
Whats the history, why did you replace all these things, had it been sitting for years or something?
IP: Logged
Dukeiboy
Member
Posts: 39
From: Hazel Green, Wisconsin
Registered: Feb 2014


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-17-2014 11:30 PM Click Here to See the Profile for DukeiboyClick Here to Email DukeiboySend a Private Message to DukeiboyEdit/Delete MessageReply w/QuoteDirect Link to This Post
Is your car automatic or standard?

------------------
Red '84, 75,000 miles.. work in progress

IP: Logged
un fiero
Member
Posts: 71
From: Houston, Texas, USA
Registered: Jun 2014


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-18-2014 05:43 PM Click Here to See the Profile for un fieroClick Here to Email un fieroSend a Private Message to un fieroEdit/Delete MessageReply w/QuoteDirect Link to This Post
Its an automatic. The car was running and driving when I got it but head gasket was slowly seeping. I do believe it probably set up some, but it has always run pretty good till recently when it started this.
IP: Logged
2.5
Member
Posts: 40903
From: Southern MN
Registered: May 2007


Feedback score: (1)
Leave feedback





Total ratings: 178
Rate this member

Report this Post09-22-2014 12:43 PM Click Here to See the Profile for 2.5Send a Private Message to 2.5Edit/Delete MessageReply w/QuoteDirect Link to This Post
IP: Logged
phonedawgz
Member
Posts: 17009
From: Green Bay, WI USA
Registered: Dec 2009


Feedback score:    (23)
Leave feedback





Total ratings: 290
Rate this member

Report this Post09-22-2014 01:10 PM Click Here to See the Profile for phonedawgzClick Here to visit phonedawgz's HomePageClick Here to Email phonedawgzSend a Private Message to phonedawgzEdit/Delete MessageReply w/QuoteDirect Link to This Post
The IAC motor rarely goes bad, and if it did that would cause the IAC to stick in one position. An up and down idle isn't going to be caused by an IAC.

A leaking EGR valve is the first place to look at for a rough idle.
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock