Pennock's Fiero Forum
  Technical Discussion & Questions
  fuel sending unit test

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
fuel sending unit test by crashmydaytona
Started on: 05-21-2014 08:20 PM
Replies: 2 (172 views)
Last post by: crashmydaytona on 05-22-2014 08:46 PM
crashmydaytona
Member
Posts: 567
From: south dakota
Registered: Apr 2013


Feedback score:    (9)
Leave feedback

Rate this member

Report this Post05-21-2014 08:20 PM Click Here to See the Profile for crashmydaytonaSend a Private Message to crashmydaytonaEdit/Delete MessageReply w/QuoteDirect Link to This Post
I am installing my fuel pump for my swap and thought i would try and fix my fuel sending unit. I can get a reading of 6-7 float down and 87-91 with the float up but i have to work really hard to get this reading i have to keep everything perfectly still or the #'s bounce all over the place and its hard to get the good reading again.
Should it be that sensitive or does this mean somthing is wrong with the sending unit?
My gauge when full reads just under half tank and when close to empty reads just over a quarter tank. Could there be somthing wrong with the gauge itself how would i diagnose it? Thanks
IP: Logged
PFF
System Bot
phonedawgz
Member
Posts: 17011
From: Green Bay, WI USA
Registered: Dec 2009


Feedback score:    (23)
Leave feedback





Total ratings: 290
Rate this member

Report this Post05-22-2014 12:45 AM Click Here to See the Profile for phonedawgzClick Here to visit phonedawgz's HomePageClick Here to Email phonedawgzSend a Private Message to phonedawgzEdit/Delete MessageReply w/QuoteDirect Link to This Post
There is way too much work in dropping the tank to try to get the old POS sending unit to work. Replace it and save your labor of doing it again.

http://www.fiero.nl/forum/A...090219-2-078597.html
IP: Logged
crashmydaytona
Member
Posts: 567
From: south dakota
Registered: Apr 2013


Feedback score:    (9)
Leave feedback

Rate this member

Report this Post05-22-2014 08:46 PM Click Here to See the Profile for crashmydaytonaSend a Private Message to crashmydaytonaEdit/Delete MessageReply w/QuoteDirect Link to This Post
I read on the forum to soak the board with the wire on it in vinegar for a few days. I just did it overnight and it works almost perfect now i get a 5 float down and 91 float up and a nice steady reading. This is close enough for me. I would suggest trying this first if your trying to repair your sending unit.
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock