Pennock's Fiero Forum
  Technical Discussion & Questions
  sudden slug

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
sudden slug by dishpro
Started on: 05-17-2014 07:41 PM
Replies: 14 (250 views)
Last post by: dishpro on 06-28-2014 12:58 PM
dishpro
Member
Posts: 30
From: bovill, idaho, usa
Registered: Nov 2009


Feedback score: N/A
Leave feedback

Rate this member

Report this Post05-17-2014 07:41 PM Click Here to See the Profile for dishproClick Here to Email dishproSend a Private Message to dishproEdit/Delete MessageReply w/QuoteDirect Link to This Post
any ideas why my 84 suddenly is running really rough ,tested compression good tried different coil , module ,map sensor,tps ,throttle body, idles okay but when rev it up and let drop back to idle gags and pukes then slowly smoothes out again , also new plugs ,wires, o2 sensor , timing gears? kinda thinkin maybe intake manifold leak any ideas would be great p.s. only about 90,000 miles total
IP: Logged
PFF
System Bot
steve308
Member
Posts: 3456
From: Stafford VA
Registered: Jan 2008


Feedback score: (2)
Leave feedback





Total ratings: 50
Rate this member

Report this Post05-17-2014 08:16 PM Click Here to See the Profile for steve308Send a Private Message to steve308Edit/Delete MessageReply w/QuoteDirect Link to This Post
Plugged exhaust (Cat converter)
IP: Logged
Csjag
Member
Posts: 3170
From: Ocklawaha,Fl, USA
Registered: Dec 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post05-17-2014 08:30 PM Click Here to See the Profile for CsjagClick Here to Email CsjagSend a Private Message to CsjagEdit/Delete MessageReply w/QuoteDirect Link to This Post
Or a fuel pump going or a clogged fuel filter
IP: Logged
dishpro
Member
Posts: 30
From: bovill, idaho, usa
Registered: Nov 2009


Feedback score: N/A
Leave feedback

Rate this member

Report this Post05-17-2014 08:36 PM Click Here to See the Profile for dishproClick Here to Email dishproSend a Private Message to dishproEdit/Delete MessageReply w/QuoteDirect Link to This Post
took cat out ,fuel pump and filter only 4000 miles on
IP: Logged
steve308
Member
Posts: 3456
From: Stafford VA
Registered: Jan 2008


Feedback score: (2)
Leave feedback





Total ratings: 50
Rate this member

Report this Post05-17-2014 08:52 PM Click Here to See the Profile for steve308Send a Private Message to steve308Edit/Delete MessageReply w/QuoteDirect Link to This Post
Second guess -- to many new parts But --- recheck timing and look for those leaks.
IP: Logged
84fiero123
Member
Posts: 29950
From: farmington, maine usa
Registered: Oct 2004


Feedback score: N/A
Leave feedback





Total ratings: 325
Rate this member

Report this Post05-17-2014 09:00 PM Click Here to See the Profile for 84fiero123Click Here to Email 84fiero123Send a Private Message to 84fiero123Edit/Delete MessageReply w/QuoteDirect Link to This Post
Take the distributer cap off and look at the pickup coil, if the insulation around it is gone it will need to be replaced. it should have a wrap of white tape like material all around the outside if any of that is missing, that would be my guess.


Steve

------------------
Technology is great when it works,
and one big pain in the ass when it doesn't



Detroit iron rules all the rest are just toys.

IP: Logged
dishpro
Member
Posts: 30
From: bovill, idaho, usa
Registered: Nov 2009


Feedback score: N/A
Leave feedback

Rate this member

Report this Post05-17-2014 09:17 PM Click Here to See the Profile for dishproClick Here to Email dishproSend a Private Message to dishproEdit/Delete MessageReply w/QuoteDirect Link to This Post
I drove to indy for the 30th anni. it was fine it started getting less power on the way home I just ordered a new pickup coil I see mine has a few cracks in the magnet also planning on replacing intake manifold gasket because I have a spare that I will polish up anyways
IP: Logged
dishpro
Member
Posts: 30
From: bovill, idaho, usa
Registered: Nov 2009


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-23-2014 02:35 AM Click Here to See the Profile for dishproClick Here to Email dishproSend a Private Message to dishproEdit/Delete MessageReply w/QuoteDirect Link to This Post
replaced intake gasket and tbi gasket compression test vacuum check still nothing found I am lost at why it's running so rich any help would be greatly appreciated

IP: Logged
dishpro
Member
Posts: 30
From: bovill, idaho, usa
Registered: Nov 2009


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-23-2014 02:37 AM Click Here to See the Profile for dishproClick Here to Email dishproSend a Private Message to dishproEdit/Delete MessageReply w/QuoteDirect Link to This Post

dishpro

30 posts
Member since Nov 2009
also rebuilt distributor and checked timing
IP: Logged
Gall757
Member
Posts: 10622
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 88
Rate this member

Report this Post06-23-2014 09:07 AM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
A bad CTS will make the engine run rich, and may not trigger a code.
IP: Logged
dishpro
Member
Posts: 30
From: bovill, idaho, usa
Registered: Nov 2009


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-23-2014 04:08 PM Click Here to See the Profile for dishproClick Here to Email dishproSend a Private Message to dishproEdit/Delete MessageReply w/QuoteDirect Link to This Post
put new cts in also .anyone know of a good way to check o2 sensor circuit? acts like not operating
IP: Logged
PFF
System Bot
Gall757
Member
Posts: 10622
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 88
Rate this member

Report this Post06-23-2014 08:24 PM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
If the O2 sensor was not working you would get a code. There may be codes saved in your ECM without the light going on.
IP: Logged
dishpro
Member
Posts: 30
From: bovill, idaho, usa
Registered: Nov 2009


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-24-2014 01:10 PM Click Here to See the Profile for dishproClick Here to Email dishproSend a Private Message to dishproEdit/Delete MessageReply w/QuoteDirect Link to This Post
there is no codes stored and i can unplug o2 sensor while running no change
IP: Logged
KurtAKX
Member
Posts: 4006
From: West Bloomfield, MI
Registered: Feb 2002


Feedback score:    (9)
Leave feedback





Total ratings: 128
Rate this member

Report this Post06-25-2014 01:39 PM Click Here to See the Profile for KurtAKXSend a Private Message to KurtAKXEdit/Delete MessageReply w/QuoteDirect Link to This Post
 
quote
Originally posted by steve308:

Plugged exhaust (Cat converter)


Sigh. If I had a dollar for every time this was inappropriately suggested...
IP: Logged
dishpro
Member
Posts: 30
From: bovill, idaho, usa
Registered: Nov 2009


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-28-2014 12:58 PM Click Here to See the Profile for dishproClick Here to Email dishproSend a Private Message to dishproEdit/Delete MessageReply w/QuoteDirect Link to This Post
as posted earlier the cat has been removed already
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock