Pennock's Fiero Forum
  Technical Discussion & Questions
  Loud front end noises, need new ball joints?

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Loud front end noises, need new ball joints? by FieroCat
Started on: 04-16-2014 11:06 AM
Replies: 2 (90 views)
Last post by: FieroCat on 04-16-2014 01:28 PM
FieroCat
Member
Posts: 270
From: Jax, Florida USA
Registered: Feb 2014


Feedback score: N/A
Leave feedback

Rate this member

Report this Post04-16-2014 11:06 AM Click Here to See the Profile for FieroCatSend a Private Message to FieroCatEdit/Delete MessageReply w/QuoteDirect Link to This Post
Just recently there has been an occasional *THUNK* sound coming from the front end whenever I let out the clutch to accelerate from a stop or brake hard. The last few days, it has gotten somewhat more frequent and much louder, making the sound even when going over slight bumps. It can be really loud and sounds exactly like a metal object being dropped on something, or like something snapping and breaking. Very disturbing sound... I was convinced for awhile that the spare tire jack was loose in the front compartment and was causing the sound, but I removed it and it still made the noise.
Do I need to replace the ball joints? Or could it be another front end component? Not too familiar with this part of the car. I just parked it for now, not going to even drive it until it get it looked at.

------------------
My Fiero: 1986 Pontiac Fiero GT, V6, 4-speed manual

[This message has been edited by FieroCat (edited 04-16-2014).]

IP: Logged
PFF
System Bot
2.5
Member
Posts: 41410
From: Southern MN
Registered: May 2007


Feedback score: (1)
Leave feedback





Total ratings: 179
Rate this member

Report this Post04-16-2014 11:47 AM Click Here to See the Profile for 2.5Send a Private Message to 2.5Edit/Delete MessageReply w/QuoteDirect Link to This Post
My first thought is a broken sway (stabilizer) bar link.

The Goldish metal colored vertical bolt in a sleeve in this image could have corroded and broke. The red parts in the image are probably black if your car is stock.

[This message has been edited by 2.5 (edited 04-16-2014).]

IP: Logged
FieroCat
Member
Posts: 270
From: Jax, Florida USA
Registered: Feb 2014


Feedback score: N/A
Leave feedback

Rate this member

Report this Post04-16-2014 01:28 PM Click Here to See the Profile for FieroCatSend a Private Message to FieroCatEdit/Delete MessageReply w/QuoteDirect Link to This Post
The part that connects to the control arm? I'll take a look at it and see.

------------------
My Fiero: 1986 Pontiac Fiero GT, V6, 4-speed manual

IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock