Pennock's Fiero Forum
  Technical Discussion & Questions
  Bad fan switch?

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Bad fan switch? by FieroCat
Started on: 04-11-2014 09:14 PM
Replies: 1 (119 views)
Last post by: LornesGT on 04-11-2014 11:55 PM
FieroCat
Member
Posts: 270
From: Jax, Florida USA
Registered: Feb 2014


Feedback score: N/A
Leave feedback

Rate this member

Report this Post04-11-2014 09:14 PM Click Here to See the Profile for FieroCatSend a Private Message to FieroCatEdit/Delete MessageReply w/QuoteDirect Link to This Post
After my oil pressure was dropping too low with the 5w-30, I switched it to 10w-30 with no change in pressure. And engine is still getting too hot even after getting new radiator, thermostat and hoses.
While this may not be related, I noticed that the radiator fan is NOT coming on at idle. It will come on when I turn the A/C on, but not when engine is running hot at idle.
Bad temperature switch in the engine block?

------------------
My Fiero: 1986 Pontiac Fiero GT, V6, 4-speed manual

IP: Logged
PFF
System Bot
LornesGT
Member
Posts: 1291
From: Granite City, IL
Registered: Jan 2013


Feedback score: (4)
Leave feedback

Rate this member

Report this Post04-11-2014 11:55 PM Click Here to See the Profile for LornesGTSend a Private Message to LornesGTEdit/Delete MessageReply w/QuoteDirect Link to This Post
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock