Pennock's Fiero Forum
  Technical Discussion & Questions
  Need help?? Engine wont run possible timing??

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Need help?? Engine wont run possible timing?? by wickedjester
Started on: 01-18-2014 12:19 PM
Replies: 14 (120 views)
Last post by: wickedjester on 01-19-2014 03:36 PM
wickedjester
Member
Posts: 115
From:
Registered: Apr 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post01-18-2014 12:19 PM Click Here to See the Profile for wickedjesterSend a Private Message to wickedjesterEdit/Delete MessageReply w/QuoteDirect Link to This Post
Have an 86 gt 2.8. Was running fine then just wouldnt start, tested it and found it had no spark, got icm tested and it was good so i replaced the coil. fixed the spark problem. now it tries to hit but sounds like it detonating. if i hold the throttle down it wil run very rough for a couple of seconds then die. It blows black smoke the whole time and by rough i mean backfiring violently the whole time. really sounds like the timing is way out. Was wondering how prone these things are to the chain slipping or loosing a tooth on the gear. Or any other ideas would be appreciated.
IP: Logged
PFF
System Bot
Gall757
Member
Posts: 10622
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 88
Rate this member

Report this Post01-18-2014 12:27 PM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
It's more likely that you moved something when you were playing with the ICM. Check connectors, make sure the pickup coil wire is not pinched under the distributor cap. Make sure the distributor did not rotate a little. Also, the ICM still might not be right....those tests are not perfect.
IP: Logged
wickedjester
Member
Posts: 115
From:
Registered: Apr 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post01-18-2014 01:10 PM Click Here to See the Profile for wickedjesterSend a Private Message to wickedjesterEdit/Delete MessageReply w/QuoteDirect Link to This Post
ok went ahead and changed icm, checked connectors they r good, no pinched wires, and cant turn the distributor, same result
IP: Logged
Gall757
Member
Posts: 10622
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 88
Rate this member

Report this Post01-18-2014 01:17 PM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
The chains have been pretty reliable on the 2.8. How many miles are on your engine?
IP: Logged
wickedjester
Member
Posts: 115
From:
Registered: Apr 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post01-18-2014 01:23 PM Click Here to See the Profile for wickedjesterSend a Private Message to wickedjesterEdit/Delete MessageReply w/QuoteDirect Link to This Post
147 and change
IP: Logged
Gall757
Member
Posts: 10622
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 88
Rate this member

Report this Post01-18-2014 01:48 PM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
IP: Logged
grkboy707
Member
Posts: 3019
From: Kingsville, MD
Registered: May 2009


Feedback score: (2)
Leave feedback

Rate this member

Report this Post01-18-2014 01:52 PM Click Here to See the Profile for grkboy707Click Here to Email grkboy707Send a Private Message to grkboy707Edit/Delete MessageReply w/QuoteDirect Link to This Post
Did you check for compression?
IP: Logged
Csjag
Member
Posts: 3170
From: Ocklawaha,Fl, USA
Registered: Dec 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post01-18-2014 02:50 PM Click Here to See the Profile for CsjagClick Here to Email CsjagSend a Private Message to CsjagEdit/Delete MessageReply w/QuoteDirect Link to This Post
Fuel pump working?
IP: Logged
wickedjester
Member
Posts: 115
From:
Registered: Apr 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post01-18-2014 02:52 PM Click Here to See the Profile for wickedjesterSend a Private Message to wickedjesterEdit/Delete MessageReply w/QuoteDirect Link to This Post
compression is ok on it i will pull a plug find tdc and see where the distributor pionts
IP: Logged
BrittB
Member
Posts: 453
From: Keizer, OR
Registered: Dec 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post01-18-2014 09:04 PM Click Here to See the Profile for BrittBSend a Private Message to BrittBEdit/Delete MessageReply w/QuoteDirect Link to This Post
I just went back through my entire ignition system and I found crimped wires on the induction coil. Installed my new spare and then I had a good spark. This was on a brand new distributor too!
IP: Logged
wickedjester
Member
Posts: 115
From:
Registered: Apr 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post01-19-2014 11:39 AM Click Here to See the Profile for wickedjesterSend a Private Message to wickedjesterEdit/Delete MessageReply w/QuoteDirect Link to This Post
ok so i checked tdc on #1 and the ditributor points right at it so no timing chain slip. Checked spark and its getting good spark. its getting plenty of fuel as well. not sure where to try next

IP: Logged
PFF
System Bot
Gall757
Member
Posts: 10622
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 88
Rate this member

Report this Post01-19-2014 01:57 PM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
Look at the vacuum lines around the MAP. If one has come off, the car can sound like that.
IP: Logged
wickedjester
Member
Posts: 115
From:
Registered: Apr 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post01-19-2014 02:49 PM Click Here to See the Profile for wickedjesterSend a Private Message to wickedjesterEdit/Delete MessageReply w/QuoteDirect Link to This Post
if it was a vacuum line wouldnt it still start?
IP: Logged
Patrick
Member
Posts: 30117
From: Vancouver, British Columbia, Canada
Registered: Apr 99


Feedback score: (1)
Leave feedback





Total ratings: 442
Rate this member

Report this Post01-19-2014 02:58 PM Click Here to See the Profile for PatrickClick Here to Email PatrickSend a Private Message to PatrickEdit/Delete MessageReply w/QuoteDirect Link to This Post

What do the plugs look like? Are they all carboned or sooted up? Proper gap?
IP: Logged
wickedjester
Member
Posts: 115
From:
Registered: Apr 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post01-19-2014 03:36 PM Click Here to See the Profile for wickedjesterSend a Private Message to wickedjesterEdit/Delete MessageReply w/QuoteDirect Link to This Post
plugs r only a couple weeks old and look good, to update a little when i crank on it, when it hits the engine kicks back hard enough to disengage the starter from the flywheel
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock