Pennock's Fiero Forum
  Technical Discussion & Questions
  Cold Air Intake For 2.3 Quad 4 motor?

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Cold Air Intake For 2.3 Quad 4 motor? by Dre13Style
Started on: 12-12-2013 10:48 AM
Replies: 8 (238 views)
Last post by: Custom2M4 on 12-14-2013 02:28 PM
Dre13Style
Member
Posts: 35
From: USA Baby!
Registered: Jun 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-12-2013 10:48 AM Click Here to See the Profile for Dre13StyleSend a Private Message to Dre13StyleEdit/Delete MessageReply w/QuoteDirect Link to This Post
Wondering if anyone has some experience with a cold air intake for a Fiero that has a Quad 4 2.3 motor in it.
I feel as though my car is starved for air and figuring a simple intake may help. Any links, DIY pics, items for sale would be super helpful.
IP: Logged
PFF
System Bot
kikinz24
Member
Posts: 729
From: OHIO
Registered: Jun 2010


Feedback score: (2)
Leave feedback

Rate this member

Report this Post12-12-2013 11:33 AM Click Here to See the Profile for kikinz24Click Here to Email kikinz24Send a Private Message to kikinz24Edit/Delete MessageReply w/QuoteDirect Link to This Post
Is the intake setup to the factory location? And what makes you think its starving for air?
IP: Logged
Dre13Style
Member
Posts: 35
From: USA Baby!
Registered: Jun 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-12-2013 11:43 AM Click Here to See the Profile for Dre13StyleSend a Private Message to Dre13StyleEdit/Delete MessageReply w/QuoteDirect Link to This Post


Not sure If I know how to post pictures on here.
It idles a bit ruff, I have done plugs, the boot and all that crap. If I could compare it to a human, just sounds like its struggeling to breath
it has a hesitation to it.
IP: Logged
rogergarrison
Member
Posts: 49593
From: A Western Caribbean Island/ Columbus, Ohio
Registered: Apr 99


Feedback score: N/A
Leave feedback





Total ratings: 552
Rate this member

Report this Post12-12-2013 12:06 PM Click Here to See the Profile for rogergarrisonClick Here to Email rogergarrisonSend a Private Message to rogergarrisonEdit/Delete MessageReply w/QuoteDirect Link to This Post
Fieros have a cold air intake from the factory...better than any aftermarket one. Only time youd need to get more air is for a big v8.
IP: Logged
kikinz24
Member
Posts: 729
From: OHIO
Registered: Jun 2010


Feedback score: (2)
Leave feedback

Rate this member

Report this Post12-12-2013 12:35 PM Click Here to See the Profile for kikinz24Click Here to Email kikinz24Send a Private Message to kikinz24Edit/Delete MessageReply w/QuoteDirect Link to This Post
Take the idi cover off and pull the coils off. check the springs under the coils they short out. And a weak coil will cause a rough idle.. I built a quad4 sky high and have probablt encountered each possible problem they can have. Also did you build the motor or know who did. If so did they play with the cams at all.. ?

[This message has been edited by kikinz24 (edited 12-12-2013).]

IP: Logged
Dre13Style
Member
Posts: 35
From: USA Baby!
Registered: Jun 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-12-2013 12:55 PM Click Here to See the Profile for Dre13StyleSend a Private Message to Dre13StyleEdit/Delete MessageReply w/QuoteDirect Link to This Post
I didn't build this frankenmachine. I got it from a guy who had it in storage for about 10 years. Car has under 40k on the body. I picked it up for $460 not a stop of rust. Oh sooooo clean undercarriage. A company in Colorado had done the swap. The owner had it shipped from Colorado to Massachusetts and couldn't get it to pass inspection. It had no E-brake set up and the shifter cables were busted. He had ordered a new cable but never could get the right one. Its a 5spd car, idk if that also came out of the beretta. I think oddly enough I ended up with the 4speed shifter cable to remedy it. I put a few thousand miles on plus a paint job/ebrake, brakes/rotors,clutch, alternator and the usual from time sitting things. Runs great just seems a bit boggy at times. I am also reading that possibly the IAT sensor could be in a poor location???? Not that I know where it is right now
IP: Logged
KurtAKX
Member
Posts: 4007
From: West Bloomfield, MI
Registered: Feb 2002


Feedback score:    (9)
Leave feedback





Total ratings: 128
Rate this member

Report this Post12-13-2013 10:37 AM Click Here to See the Profile for KurtAKXSend a Private Message to KurtAKXEdit/Delete MessageReply w/QuoteDirect Link to This Post
Does the check engine light work?

For example, key on, engine off, does it illuminate?
IP: Logged
Dre13Style
Member
Posts: 35
From: USA Baby!
Registered: Jun 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-13-2013 10:44 AM Click Here to See the Profile for Dre13StyleSend a Private Message to Dre13StyleEdit/Delete MessageReply w/QuoteDirect Link to This Post
The check engine does seem to work. I know once in a rare blue moon it will come on mid way through a drive. Next time I start the car its no longer on though.
IP: Logged
Custom2M4
Member
Posts: 4414
From: Winnipeg, Manitoba Canada
Registered: Sep 2004


Feedback score: (3)
Leave feedback





Total ratings: 114
Rate this member

Report this Post12-14-2013 02:28 PM Click Here to See the Profile for Custom2M4Click Here to Email Custom2M4Send a Private Message to Custom2M4Edit/Delete MessageReply w/QuoteDirect Link to This Post
If the air filter is clean, it won't be struggling because of the intake. Have the codes checked, becuase it might be a sensor causing your issue.

------------------

IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock