Pennock's Fiero Forum
  Technical Discussion & Questions
  No check engine light at all also don't hear fuel pump priming

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
No check engine light at all also don't hear fuel pump priming by Shonyman32
Started on: 11-22-2013 04:16 PM
Replies: 5 (342 views)
Last post by: Shonyman32 on 11-23-2013 07:48 PM
Shonyman32
Member
Posts: 566
From: Shelbyville, IN
Registered: Jan 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post11-22-2013 04:16 PM Click Here to See the Profile for Shonyman32Send a Private Message to Shonyman32Edit/Delete MessageReply w/QuoteDirect Link to This Post
I have no check engine light when I turn my key to the on position or when cranking.
My fuel pump is not priming.
Car suddenly died when started up and driving home from work. Died after about 30 seconds of driving home after starting.
IP: Logged
PFF
System Bot
2.5
Member
Posts: 40903
From: Southern MN
Registered: May 2007


Feedback score: (1)
Leave feedback





Total ratings: 178
Rate this member

Report this Post11-22-2013 04:40 PM Click Here to See the Profile for 2.5Send a Private Message to 2.5Edit/Delete MessageReply w/QuoteDirect Link to This Post
Without hearing the pump its most likley the pump.
But when you turn your key to the on position what lights do light up?

[This message has been edited by 2.5 (edited 11-22-2013).]

IP: Logged
Shonyman32
Member
Posts: 566
From: Shelbyville, IN
Registered: Jan 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post11-22-2013 04:56 PM Click Here to See the Profile for Shonyman32Send a Private Message to Shonyman32Edit/Delete MessageReply w/QuoteDirect Link to This Post
Brake ajar and thermostat.
Also the pump is less than a year old. I bought it in February and installed it in march and only have 4700 miles on the new pump.
IP: Logged
AL68
Member
Posts: 305
From: Omaha, NE
Registered: Oct 2011


Feedback score:    (18)
Leave feedback

Rate this member

Report this Post11-23-2013 01:19 AM Click Here to See the Profile for AL68Click Here to Email AL68Send a Private Message to AL68Edit/Delete MessageReply w/QuoteDirect Link to This Post
The check engine light should come on if the pcm is turning on, the pcm turns on the fuel pump relay. Check for blown pcm fuses in the fuse block & the 1-wire fusible link connector (clears pcm memory) by the battery.
IP: Logged
phonedawgz
Member
Posts: 17009
From: Green Bay, WI USA
Registered: Dec 2009


Feedback score:    (23)
Leave feedback





Total ratings: 290
Rate this member

Report this Post11-23-2013 12:38 PM Click Here to See the Profile for phonedawgzClick Here to visit phonedawgz's HomePageClick Here to Email phonedawgzSend a Private Message to phonedawgzEdit/Delete MessageReply w/QuoteDirect Link to This Post
If it's an 84 - Most likely the problem is loose wires or a broken fusible link at the starter.

If 85+ check the ECM reset connector. With no light and no fuel pump it sounds like your ECM isn't working. Most likely the problem with a non-functioning ECM is that it is not getting the proper power to it. There are two power wires to the ECM, one switched and one unswitched. It will not function unless it has power on both leads.

IP: Logged
Shonyman32
Member
Posts: 566
From: Shelbyville, IN
Registered: Jan 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post11-23-2013 07:48 PM Click Here to See the Profile for Shonyman32Send a Private Message to Shonyman32Edit/Delete MessageReply w/QuoteDirect Link to This Post
Thank you guys very much. My water pump pulley had grinded through the ECM reset connector.
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock