Pennock's Fiero Forum
  Technical Discussion & Questions
  Accelleration issue

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Accelleration issue by 4thfiero
Started on: 10-17-2013 05:20 PM
Replies: 5 (110 views)
Last post by: Bloozberry on 10-18-2013 07:49 AM
4thfiero
Member
Posts: 801
From: Winnipeg, Manitoba, Canada
Registered: Oct 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post10-17-2013 05:20 PM Click Here to See the Profile for 4thfieroClick Here to Email 4thfieroSend a Private Message to 4thfieroEdit/Delete MessageReply w/QuoteDirect Link to This Post
2.8 v6 88 Fiero

Having a power issue with it, feels very sluggish. No check engine light. took it to my mechanic, electronics are all good. Fuel and spark are good. But did a smoke test and checked for vacuum leaks, found 2, one is that thick hose under the upper plenum, the 2nd is where the lower plenum mates with the block. Tech thinks that bcc of those intake leaks. The engine isnt getting enough air to all the cylinders.

Could that be my power issue?
IP: Logged
PFF
System Bot
Gall757
Member
Posts: 10657
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 88
Rate this member

Report this Post10-17-2013 05:57 PM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
don't think so. What's your idle speed?
IP: Logged
f85gtron
Member
Posts: 657
From: Augusta, Ga. USA
Registered: Jul 2013


Feedback score: (3)
Leave feedback

Rate this member

Report this Post10-17-2013 06:02 PM Click Here to See the Profile for f85gtronSend a Private Message to f85gtronEdit/Delete MessageReply w/QuoteDirect Link to This Post
probably getting too much air. is your idle high?
IP: Logged
4thfiero
Member
Posts: 801
From: Winnipeg, Manitoba, Canada
Registered: Oct 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post10-17-2013 06:21 PM Click Here to See the Profile for 4thfieroClick Here to Email 4thfieroSend a Private Message to 4thfieroEdit/Delete MessageReply w/QuoteDirect Link to This Post
Idle is fine, either right at 1k or JUST under, steady idle.
IP: Logged
4thfiero
Member
Posts: 801
From: Winnipeg, Manitoba, Canada
Registered: Oct 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post10-17-2013 09:13 PM Click Here to See the Profile for 4thfieroClick Here to Email 4thfieroSend a Private Message to 4thfieroEdit/Delete MessageReply w/QuoteDirect Link to This Post
When its warmed up that is...idle seems fine, only other symptoms are a slight hesitation on accel when the engine is cold. Like its about to stall, and the engine sounds a bit louder than normal
IP: Logged
Bloozberry
Member
Posts: 7760
From:
Registered: Jan 2009


Feedback score: N/A
Leave feedback





Total ratings: 307
Rate this member

Report this Post10-18-2013 07:49 AM Click Here to See the Profile for BloozberrySend a Private Message to BloozberryEdit/Delete MessageReply w/QuoteDirect Link to This Post
It could be your cat or your muffler are choked off with internal failure of the baffles.
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock