Pennock's Fiero Forum
  Technical Discussion & Questions
  Turn signals and windows slow

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Turn signals and windows slow by Jmac2472
Started on: 09-29-2013 06:38 PM
Replies: 5 (153 views)
Last post by: theogre on 09-30-2013 07:49 PM
Jmac2472
Junior Member
Posts: 5
From: Saskatoon,Saskatchewan,Canada
Registered: Aug 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-29-2013 06:38 PM Click Here to See the Profile for Jmac2472Click Here to Email Jmac2472Send a Private Message to Jmac2472Edit/Delete MessageReply w/QuoteDirect Link to This Post
Does any one know why I would have slow flashing turn signals? My power windows also are very slow. It's seems the battery gauge dips pretty low when they're on. Any way to get more power ?
Thanks
IP: Logged
PFF
System Bot
NetCam
Member
Posts: 1490
From: Milton, Ontario, Canada
Registered: Mar 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-29-2013 08:30 PM Click Here to See the Profile for NetCamClick Here to visit NetCam's HomePageSend a Private Message to NetCamEdit/Delete MessageReply w/QuoteDirect Link to This Post
Sounds like a bad ground
IP: Logged
theogre
Member
Posts: 29206
From: USA
Registered: Mar 99


Feedback score: N/A
Leave feedback





Total ratings: 549
Rate this member

Report this Post09-29-2013 10:46 PM Click Here to See the Profile for theogreClick Here to visit theogre's HomePageSend a Private Message to theogreEdit/Delete MessageReply w/QuoteDirect Link to This Post
Iffy ground(s) and/or power.

See my Cave, Wire Service

------------------
Dr. Ian Malcolm: Yeah, but your scientists were so preoccupied with whether or not they could, they didn't stop to think if they should.
(Jurassic Park)


The Ogre's Fiero Cave (It's also at the top and bottom of every forum page...)

IP: Logged
northstar
Member
Posts: 203
From: indiana,p.a.
Registered: Aug 2013


Feedback score: N/A
Leave feedback

User Banned

Report this Post09-30-2013 04:37 PM Click Here to See the Profile for northstarClick Here to Email northstarSend a Private Message to northstarEdit/Delete MessageReply w/QuoteDirect Link to This Post
they are all slow as far as I know,, at least yours are working....
IP: Logged
4thfiero
Member
Posts: 801
From: Winnipeg, Manitoba, Canada
Registered: Oct 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-30-2013 06:14 PM Click Here to See the Profile for 4thfieroClick Here to Email 4thfieroSend a Private Message to 4thfieroEdit/Delete MessageReply w/QuoteDirect Link to This Post
Agreed, bad ground, same thing happened to me, it was my rear tail lights ground on the passenger side of the vehicle inside the rear wheel well.

Other symptoms I had were the signal lights were VERY dim and at night time, i could hit my brake pedal with my interior lights OFF, and my interior lights would very dimly come on inside the car every time i hot my break pedal...the electricity was searching for a ground back to the fuse box i think. One the ground was repaired all those wierd symptoms went away in one shot.
IP: Logged
theogre
Member
Posts: 29206
From: USA
Registered: Mar 99


Feedback score: N/A
Leave feedback





Total ratings: 549
Rate this member

Report this Post09-30-2013 07:49 PM Click Here to See the Profile for theogreClick Here to visit theogre's HomePageSend a Private Message to theogreEdit/Delete MessageReply w/QuoteDirect Link to This Post
also See my Cave, Sneak Path

You likely have more problem than main grounds/power.

[This message has been edited by theogre (edited 09-30-2013).]

IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock