Pennock's Fiero Forum
  Technical Discussion & Questions
  Headlight relay

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Headlight relay by chorcob
Started on: 07-08-2013 07:58 PM
Replies: 4 (214 views)
Last post by: chorcob on 07-08-2013 10:55 PM
chorcob
Member
Posts: 160
From: Calumet, MI
Registered: Jun 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post07-08-2013 07:58 PM Click Here to See the Profile for chorcobSend a Private Message to chorcobEdit/Delete MessageReply w/QuoteDirect Link to This Post
On my 1986 fiero se the passenger side headlight relay keeps clicking and then when the knob is turned and the switch engages it stops clicking. The motor was rebuilt cause the light wouldn't go down and it still clicks. it does go down now though. But, why does it keep clicking even when the headlights and car are off? Do i need a new relay? Gonna interchange the relays later, but just thought you guys
might have some input.

------------------
Unconditional Surrender

IP: Logged
PFF
System Bot
NetCam
Member
Posts: 1490
From: Milton, Ontario, Canada
Registered: Mar 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post07-08-2013 08:01 PM Click Here to See the Profile for NetCamClick Here to visit NetCam's HomePageSend a Private Message to NetCamEdit/Delete MessageReply w/QuoteDirect Link to This Post
Are you sure it's the relay that's clicking and not the limit switch? Is the knob on top twitching when it clicks?
IP: Logged
chorcob
Member
Posts: 160
From: Calumet, MI
Registered: Jun 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post07-08-2013 08:22 PM Click Here to See the Profile for chorcobSend a Private Message to chorcobEdit/Delete MessageReply w/QuoteDirect Link to This Post
yeah its the relay, it keeps clicking and then you turn the knob slightly and the limit switch clicks, then the relay doesn't click anymore

------------------
Unconditional Surrender

IP: Logged
fierofool
Member
Posts: 11866
From: Auburn, Georgia USA
Registered: Jan 2002


Feedback score:    (13)
Leave feedback





Total ratings: 151
Rate this member

Report this Post07-08-2013 09:21 PM Click Here to See the Profile for fierofoolClick Here to visit fierofool's HomePageClick Here to Email fierofoolSend a Private Message to fierofoolEdit/Delete MessageReply w/QuoteDirect Link to This Post
A common cause of that is that the rubber weather seal underneath the knob often slides up underneath the knob when reassembling. This is especially true for anyone who's rebuilding their motors for the first time. Another cause can be that when you slid the limiter switch back into the housing, one of the brushes caught the commutator and popped off. The motor can't develop enough speed or torque to fully open the points.

If you find that it isn't the relays, you'll need to remove the headlight assembly and look underneath the motor to see if the rubber seal is down into the top of the housing or just sitting on top. In the meantime, unplug the single blue wire connector to prevent damage to the motor or draining the battery.
IP: Logged
chorcob
Member
Posts: 160
From: Calumet, MI
Registered: Jun 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post07-08-2013 10:55 PM Click Here to See the Profile for chorcobSend a Private Message to chorcobEdit/Delete MessageReply w/QuoteDirect Link to This Post
interchanged the relays and that solved the problem, gonna go to auto value for a new one tomorrow

Thanks for the input

------------------
Unconditional Surrender

IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock