Pennock's Fiero Forum
  Technical Discussion & Questions
  Broken Bracket in Front Bumper Area?

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Broken Bracket in Front Bumper Area? by kriswinner
Started on: 07-06-2013 10:24 PM
Replies: 2 (213 views)
Last post by: Indiana_resto_guy on 07-07-2013 06:53 PM
kriswinner
Member
Posts: 151
From: Metro Detroit, MI
Registered: May 2009


Feedback score: (2)
Leave feedback

Rate this member

Report this Post07-06-2013 10:24 PM Click Here to See the Profile for kriswinnerSend a Private Message to kriswinnerEdit/Delete MessageReply w/QuoteDirect Link to This Post
I'm in the process of reinstalling my front bumper on my Formula after paint.
I think I've got a broken bracket mounting point on the car. Looking for a little help in confirming...

This is the bracket that I'm trying to install.


This is where it goes (Parts Catalog)


This is a picture from under my car, facing the front. It looks like the part that the bracket would attach to is broken.
If memory serves, this area was pretty rusted before I POR-15'd everything.


Just looking for confirmation that I'll need to fab something up.
If anyone has a picture of how it is supposed to look from that perspective, that would be very helpful.

Thanks!
IP: Logged
PFF
System Bot
olejoedad
Member
Posts: 14221
From: Clarendon Twp., MI
Registered: May 2004


Feedback score: (5)
Leave feedback





Total ratings: 190
Rate this member

Report this Post07-07-2013 08:56 AM Click Here to See the Profile for olejoedadClick Here to Email olejoedadSend a Private Message to olejoedadEdit/Delete MessageReply w/QuoteDirect Link to This Post
You are missing a bit of the mount. The tab that the support attaches to has rusted off. Its the same size as the end of the support., about an inch by an inch.
IP: Logged
Indiana_resto_guy
Member
Posts: 7158
From: Shelbyville, IN USA
Registered: Jul 2000


Feedback score:    (15)
Leave feedback





Total ratings: 163
Rate this member

Report this Post07-07-2013 06:53 PM Click Here to See the Profile for Indiana_resto_guyClick Here to Email Indiana_resto_guySend a Private Message to Indiana_resto_guyEdit/Delete MessageReply w/QuoteDirect Link to This Post
 
quote
Originally posted by olejoedad:

You are missing a bit of the mount. The tab that the support attaches to has rusted off. Its the same size as the end of the support., about an inch by an inch.


That would be item 12 in the pic.
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock