Pennock's Fiero Forum
  Technical Discussion & Questions
  ICM relocation

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
ICM relocation by Ridgelandbaseball
Started on: 07-04-2014 12:10 AM
Replies: 2 (143 views)
Last post by: mmeyer86gt/gtp on 07-04-2014 02:41 AM
Ridgelandbaseball
Member
Posts: 383
From: North Ridgeville, Ohio USA
Registered: Aug 2009


Feedback score: (5)
Leave feedback

Rate this member

Report this Post07-04-2014 12:10 AM Click Here to See the Profile for RidgelandbaseballClick Here to Email RidgelandbaseballSend a Private Message to RidgelandbaseballEdit/Delete MessageReply w/QuoteDirect Link to This Post
On my way back from Fierorama last year. (350 miles) I blew 3 icm's. None on the way there. I figured it was the heat since it was very warm out and I installed mini headers on my 2.8 which causes a lot more heat. I decided to move the icm to the trunk area as some have. We replaced the coil and repaired and extended some wiring to put icm into truck. Still no start. At first we did not have the icm grounded. We then screwed it into the front trunk wall. Still no start. Is screwing to the wall enough ground or should we take the paint off the wall for a better ground. It appears we are blowing icms everytime we try. Also, noticed the check engine light is not coming on while trying to start.

[This message has been edited by Ridgelandbaseball (edited 07-04-2014).]

IP: Logged
PFF
System Bot
phonedawgz
Member
Posts: 17011
From: Green Bay, WI USA
Registered: Dec 2009


Feedback score:    (23)
Leave feedback





Total ratings: 290
Rate this member

Report this Post07-04-2014 01:55 AM Click Here to See the Profile for phonedawgzClick Here to visit phonedawgz's HomePageClick Here to Email phonedawgzSend a Private Message to phonedawgzEdit/Delete MessageReply w/QuoteDirect Link to This Post
No power to the ECM.
IP: Logged
mmeyer86gt/gtp
Member
Posts: 3669
From: galt, ca
Registered: Sep 2001


Feedback score:    (159)
Leave feedback





Total ratings: 71
Rate this member

Report this Post07-04-2014 02:41 AM Click Here to See the Profile for mmeyer86gt/gtpClick Here to Email mmeyer86gt/gtpSend a Private Message to mmeyer86gt/gtpEdit/Delete MessageReply w/QuoteDirect Link to This Post
check corrosion on the distributor fingers for the reason you are blowing modules or your magnet has gone bad. ICM's dont just go bad they get heated up because the distributor is requiring more energy to get the same spark through because of the rust corrosion FYI.
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock