Pennock's Fiero Forum
  Technical Discussion & Questions
  Fixed fuel filling problem and 3800 installed in 87gt

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Fixed fuel filling problem and 3800 installed in 87gt by KY87fierogt
Started on: 06-28-2014 09:58 AM
Replies: 0 (83 views)
Last post by: KY87fierogt on 06-28-2014 09:58 AM
KY87fierogt
Member
Posts: 73
From: Kimper, ky, USA
Registered: Mar 2013


Feedback score: (2)
Leave feedback

Rate this member

Report this Post06-28-2014 09:58 AM Click Here to See the Profile for KY87fierogtClick Here to Email KY87fierogtSend a Private Message to KY87fierogtEdit/Delete MessageReply w/QuoteDirect Link to This Post
I had been having issues with filling the fuel tank with fuel. On empty it would only hold 8gal and you would have to barely hold the trigger on the pump to put fuel in,...even then the pump would kick off 20+ times while filling. Since I had to change the pump for the swap anyways I figured it would be a great time to check it out( I had already checked the vent lines before). The locking mechanism on the baffle had broke, which allowed it to slide forward. The fill and vent tubes were sitting directly behind the baffle. My fix was to guide the tubes back through the baffle slide the baffle back and put a SS hose clamp on the vent lint to prevent the baffle from moving again.

I'm currently a student and use my fiero as a DD. It broke down on me several times while coming home from school, so I decided to do a swap with a lower mileage 3800 na over summer break. I bought several parts from vendors on here to expedite the process and finished it in roughly 6-7 weeks. First test drive was yesterday and it was AMAZING!! It runs ridiculously smooth.

There are countless people that helped without even realizing it. I have poured over so many threads getting info i can't keep them straight, so I would like to give out a general thanks to the entire pennocks community!

Fierorog......flywheel and front engine mount.....fit and finish were absolutely amazing
Phonedawgz....PCM and harness....your reputation precedes you. The harness looked great and the engine came alive on the first attempt at starting

The gt swap is finished. Now I have to tear the 440t4 for my other fiero apart and figure out why it doesn't engage. Put it in any gear and nothing. When you shut the engine off you can hear a 'spinning' sound coming from the transmission(yep I checked to make sure the flywheel/TC bolts are in). The sound SEEMS to come from the bell housing area. Gonna try to have it out and in the garage tonight. This will be the first time for me to tear a transmission apart. I bought a book and watched it on you tube so I'm an expert now(umm,.this was a joke). Any advise on this is DEF appreciated!
IP: Logged
PFF
System Bot



All times are ET (US)
next newest topic | next oldest topic

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock