Pennock's Fiero Forum
  Technical Discussion & Questions
  Headlight motors being a pain

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
Headlight motors being a pain by FieroSE757
Started on: 05-31-2014 09:04 PM
Replies: 1 (51 views)
Last post by: NetCam on 05-31-2014 10:30 PM
FieroSE757
Member
Posts: 59
From: chesapeake,va,usa
Registered: Feb 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post05-31-2014 09:04 PM Click Here to See the Profile for FieroSE757Send a Private Message to FieroSE757Edit/Delete MessageReply w/QuoteDirect Link to This Post
Hey guys, i have a 85 Se with 1st gen headlight motors. well now my lights will not go up. i hit the switch and nothing you can hear the clicking but no movement. now i have rebuilt the pass side with a metal gear and it wont go up but i can manually crank it up and when i flip the switch it goes down but nothing on the driver side. just the bulb comes on. Im thrown for a loop any help would be great.
IP: Logged
PFF
System Bot
NetCam
Member
Posts: 1490
From: Milton, Ontario, Canada
Registered: Mar 2012


Feedback score: N/A
Leave feedback

Rate this member

Report this Post05-31-2014 10:30 PM Click Here to See the Profile for NetCamClick Here to visit NetCam's HomePageSend a Private Message to NetCamEdit/Delete MessageReply w/QuoteDirect Link to This Post
Check youtube, buddycraigg has a series of videos on troubleshotoing the Gen 1 motors. When you saying clicking, is it just like a little ping, or is it all out grinding?
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock