Pennock's Fiero Forum
  General Fiero Chat
  84 clutch is very stiff when car is cold

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
84 clutch is very stiff when car is cold by bradleypridgeon
Started on: 08-16-2014 02:57 PM
Replies: 2 (81 views)
Last post by: rogergarrison on 08-18-2014 04:57 PM
bradleypridgeon
Junior Member
Posts: 7
From: hastings mn
Registered: Aug 2014


Feedback score: N/A
Leave feedback

Rate this member

Report this Post08-16-2014 02:57 PM Click Here to See the Profile for bradleypridgeonSend a Private Message to bradleypridgeonEdit/Delete MessageReply w/QuoteDirect Link to This Post
I have an all original 84 with 87k miles on it. Its a 4 speed and I have had the best of luck with it, but there is one issue that is really bothersome. Thats anytime i start the car cold, for the first couple of minutes of driving it (if i don't lket it sit and warm up) The clutch will be very stiff, not so much as far as pedal movement, but it will be very quick to engage, there is no way to feather it and its almos t impossible to take off at times until i let it sit and warm up. Any idea what this is and what solution there is?

This is my first post btw.
IP: Logged
PFF
System Bot
Csjag
Member
Posts: 3170
From: Ocklawaha,Fl, USA
Registered: Dec 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post08-17-2014 08:51 AM Click Here to See the Profile for CsjagClick Here to Email CsjagSend a Private Message to CsjagEdit/Delete MessageReply w/QuoteDirect Link to This Post
I would check the clutch master cylinder, it may be clogged up with congealed old fluid and when you first start it takes a few pumps to get the cylinder moving freely without sticking. Welcome to the forum, there are a lot of great knowledgeable and helpful people on here.
IP: Logged
rogergarrison
Member
Posts: 49593
From: A Western Caribbean Island/ Columbus, Ohio
Registered: Apr 99


Feedback score: N/A
Leave feedback





Total ratings: 552
Rate this member

Report this Post08-18-2014 04:57 PM Click Here to See the Profile for rogergarrisonClick Here to Email rogergarrisonSend a Private Message to rogergarrisonEdit/Delete MessageReply w/QuoteDirect Link to This Post
Maybe the yoke pivot shaft grease has dried up. Only way to lube it is pull the tranny. I dont know why GM didnt put a grease fitting on it.
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock