Pennock's Fiero Forum
  General Fiero Chat
  New guy

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
New guy by BrittB
Started on: 12-15-2013 04:13 PM
Replies: 11 (209 views)
Last post by: pontiackid86 on 12-17-2013 09:16 AM
BrittB
Member
Posts: 453
From: Keizer, OR
Registered: Dec 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-15-2013 04:13 PM Click Here to See the Profile for BrittBSend a Private Message to BrittBEdit/Delete MessageReply w/QuoteDirect Link to This Post
First time posting here but have been reading the forums for a while now and learning much. I have a project 85 SE V6 auto that I'm slowly getting back to running condition and with the help found here I hope to get it back on the road someday soon, thanks!
IP: Logged
PFF
System Bot
craigsfiero2007
Member
Posts: 3979
From: Livermore, ME
Registered: Aug 2007


Feedback score:    (9)
Leave feedback





Total ratings: 71
Rate this member

Report this Post12-15-2013 04:18 PM Click Here to See the Profile for craigsfiero2007Click Here to Email craigsfiero2007Send a Private Message to craigsfiero2007Edit/Delete MessageReply w/QuoteDirect Link to This Post
Welcome to the Addiction! Post some pics of your beast.
IP: Logged
Gall757
Member
Posts: 10633
From: Holland, MI
Registered: Jun 2010


Feedback score: N/A
Leave feedback





Total ratings: 88
Rate this member

Report this Post12-15-2013 05:53 PM Click Here to See the Profile for Gall757Send a Private Message to Gall757Edit/Delete MessageReply w/QuoteDirect Link to This Post
Welcome to the Forum!
IP: Logged
BrittB
Member
Posts: 453
From: Keizer, OR
Registered: Dec 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-15-2013 06:18 PM Click Here to See the Profile for BrittBSend a Private Message to BrittBEdit/Delete MessageReply w/QuoteDirect Link to This Post
This is what it looked like when I picked it up, wasn't a runner then but the price was right. A bunch of money later, it still doesn't run!




IP: Logged
BrittB
Member
Posts: 453
From: Keizer, OR
Registered: Dec 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-15-2013 06:33 PM Click Here to See the Profile for BrittBSend a Private Message to BrittBEdit/Delete MessageReply w/QuoteDirect Link to This Post
So far I've replaced the entire ignition system, fuel injection system has been completely rebuilt, new gaskets on the intake, (middle and upper), egr delete with the proper chip, and most sensors replaced with new because the orignals were removed for another car. I've driven it about 50 yards tops! It almost sounds like it may have a burnt valve because of a popping/ backfing noise coming out the exhaust so yarding off the heads may be my next adventure. It's a damn good thing I like the car and got into it for cheap or it might have found a home elsewhere instead of my garage. I came really close to going the carbed route with it too and still wish I had, that I know how to sort out
IP: Logged
craigsfiero2007
Member
Posts: 3979
From: Livermore, ME
Registered: Aug 2007


Feedback score:    (9)
Leave feedback





Total ratings: 71
Rate this member

Report this Post12-15-2013 06:37 PM Click Here to See the Profile for craigsfiero2007Click Here to Email craigsfiero2007Send a Private Message to craigsfiero2007Edit/Delete MessageReply w/QuoteDirect Link to This Post
Looks like a good starting point for a project. Start your own thread in the Tech Section, if you haven't already, with all of your problems you are having in getting it running. Surely someone will come along with the solution to your problem and could save you some money.
IP: Logged
BrittB
Member
Posts: 453
From: Keizer, OR
Registered: Dec 2013


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-15-2013 06:46 PM Click Here to See the Profile for BrittBSend a Private Message to BrittBEdit/Delete MessageReply w/QuoteDirect Link to This Post
I've been kicking around the idea of building a 3.4 for it while I drive it but that hasn't happened. The first things I need to do is double check the timing and read the plugs along with a compression check. Just waiting to get my compression tester back from a friend!
IP: Logged
Alex4mula
Member
Posts: 7395
From: Lake Worth, FL,US
Registered: Dec 1999


Feedback score:    (11)
Leave feedback





Total ratings: 153
Rate this member

Report this Post12-16-2013 01:06 PM Click Here to See the Profile for Alex4mulaClick Here to Email Alex4mulaSend a Private Message to Alex4mulaEdit/Delete MessageReply w/QuoteDirect Link to This Post
Welcome. Nice to see new people picking up these cars to restore.
IP: Logged
N3M3S1S
Member
Posts: 3865
From: Newark, DE
Registered: Dec 2007


Feedback score:    (6)
Leave feedback





Total ratings: 51
Rate this member

Report this Post12-16-2013 06:00 PM Click Here to See the Profile for N3M3S1SClick Here to visit N3M3S1S's HomePageClick Here to Email N3M3S1SSend a Private Message to N3M3S1SEdit/Delete MessageReply w/QuoteDirect Link to This Post
Bumperpad V6? That's my favorite Fiero body. Good luck! I'm in the "faded red paint" club too!
IP: Logged
ltlfrari
Member
Posts: 5263
From: Wake Forest,NC,USA
Registered: Jan 2002


Feedback score: (4)
Leave feedback





Total ratings: 127
Rate this member

Report this Post12-16-2013 08:30 PM Click Here to See the Profile for ltlfrariClick Here to visit ltlfrari's HomePageClick Here to Email ltlfrariSend a Private Message to ltlfrariEdit/Delete MessageReply w/QuoteDirect Link to This Post
 
quote
Originally posted by BrittB:

A bunch of money later, it still doesn't run!



That pretty much sums up Fiero ownership !
Welcome to the madness.

------------------
Anything I might say is probably worth what you paid for it, so treat it accordingly!

Dave

www.ltlfrari.com

IP: Logged
no2pencil
Member
Posts: 1494
From: Baltimore, MD
Registered: Oct 2009


Feedback score: (3)
Leave feedback

Rate this member

Report this Post12-17-2013 07:36 AM Click Here to See the Profile for no2pencilClick Here to Email no2pencilSend a Private Message to no2pencilEdit/Delete MessageReply w/QuoteDirect Link to This Post
 
quote
Originally posted by BrittB:
A bunch of money later, it still doesn't run!

Familiar story! lol

Welcome!!
IP: Logged
PFF
System Bot
pontiackid86
Member
Posts: 19600
From: Kingwood Texas..... Yall
Registered: Sep 2008


Feedback score:    (12)
Leave feedback





Total ratings: 342
Rate this member

Report this Post12-17-2013 09:16 AM Click Here to See the Profile for pontiackid86Click Here to Email pontiackid86Send a Private Message to pontiackid86Edit/Delete MessageReply w/QuoteDirect Link to This Post
 
quote
Originally posted by BrittB:

A bunch of money later, it still doesn't run!



Story of my life with my 3

IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock