Pennock's Fiero Forum
  General Fiero Chat
  ignition control module? HELP

Post New Topic  Post A Reply
Email This Page to Someone! | Printable Version


next newest topic | next oldest topic
ignition control module? HELP by heavyRfoot
Started on: 11-29-2013 06:24 PM
Replies: 7 (288 views)
Last post by: heavyRfoot on 12-01-2013 06:50 PM
heavyRfoot
Member
Posts: 627
From: york, pa
Registered: May 2007


Feedback score: (2)
Leave feedback

Rate this member

Report this Post11-29-2013 06:24 PM Click Here to See the Profile for heavyRfootClick Here to Email heavyRfootSend a Private Message to heavyRfootEdit/Delete MessageReply w/QuoteDirect Link to This Post
ok so was driving her around today and all of a sudden she started to spit and sputter and shut down. well I was low on gas so I filled it up and still the same thing well got it back to somewhat of a safe area shut it down for about 30 min. went out to restart it it cranked over and started for about a sec. after that all it did was crank and crank nothing haven't check to see if it has spark yet but I know its getting gas since I hit the valve and it sprayed me. also when it was spitting the rpms would jump up and down. so does this sound like the control module
IP: Logged
PFF
System Bot
maybenot
Member
Posts: 173
From: ny 85 v6
Registered: Jun 2013


Feedback score: (2)
Leave feedback

Rate this member

Report this Post11-29-2013 06:52 PM Click Here to See the Profile for maybenotClick Here to Email maybenotSend a Private Message to maybenotEdit/Delete MessageReply w/QuoteDirect Link to This Post
gotta post this in technical forum, sorry i cant help
IP: Logged
heavyRfoot
Member
Posts: 627
From: york, pa
Registered: May 2007


Feedback score: (2)
Leave feedback

Rate this member

Report this Post11-29-2013 07:49 PM Click Here to See the Profile for heavyRfootClick Here to Email heavyRfootSend a Private Message to heavyRfootEdit/Delete MessageReply w/QuoteDirect Link to This Post
Sorry about wrong section been a while since I posted on here and was in a hurry. So it isn't getting spark I did just check that a little bit ago
IP: Logged
mrfiero
Member
Posts: 8986
From: Colorful Colorado
Registered: Mar 99


Feedback score:    (90)
Leave feedback





Total ratings: 149
Rate this member

Report this Post11-29-2013 08:07 PM Click Here to See the Profile for mrfieroClick Here to Email mrfieroSend a Private Message to mrfieroEdit/Delete MessageReply w/QuoteDirect Link to This Post
No spark could be the coil, ignition control module or the pick-up coil.

The pessimist in me says remove the distributor cap and watch the rotor as someone cranks the engine over. If the rotor doesn't spin then your timing chain broke, This is unlikely to be the problem, but it happened to me once many years ago and it took a long time to figure it out.
IP: Logged
Fiero Thomas
Member
Posts: 4602
From: Round Lake Beach, IL
Registered: Jul 2005


Feedback score:    (170)
Leave feedback





Total ratings: 125
Rate this member

Report this Post11-29-2013 09:06 PM Click Here to See the Profile for Fiero ThomasClick Here to visit Fiero Thomas's HomePageClick Here to Email Fiero ThomasSend a Private Message to Fiero ThomasEdit/Delete MessageReply w/QuoteDirect Link to This Post
When you crank the motor if the tach does not bounce then its the ICM.

------------------
1986 Fiero GT 1984 Corvette
1992 Bonneville SSEI 2009 Dodge Challenger SRT8

FieroNews

IP: Logged
1MohrFiero
Member
Posts: 4363
From: Paducah, Ky
Registered: Apr 2003


Feedback score:    (37)
Leave feedback





Total ratings: 157
Rate this member

Report this Post11-30-2013 09:47 AM Click Here to See the Profile for 1MohrFieroSend a Private Message to 1MohrFieroEdit/Delete MessageReply w/QuoteDirect Link to This Post
It sounds very much like the ICM, I went through almost the same scenario when I first got my car. If that doesn't fix it check the coil next. Many times the two go out together.

------------------

IP: Logged
maybenot
Member
Posts: 173
From: ny 85 v6
Registered: Jun 2013


Feedback score: (2)
Leave feedback

Rate this member

Report this Post11-30-2013 05:48 PM Click Here to See the Profile for maybenotClick Here to Email maybenotSend a Private Message to maybenotEdit/Delete MessageReply w/QuoteDirect Link to This Post
i just reread my comment. to be clear, i didnt mean i wont help because you posted here, i was trying to steer you to get more replys.
IP: Logged
heavyRfoot
Member
Posts: 627
From: york, pa
Registered: May 2007


Feedback score: (2)
Leave feedback

Rate this member

Report this Post12-01-2013 06:50 PM Click Here to See the Profile for heavyRfootClick Here to Email heavyRfootSend a Private Message to heavyRfootEdit/Delete MessageReply w/QuoteDirect Link to This Post
Ok its now going again it was the icm. Plus the distubutor was loose so had to retime it by ear. But now my tach filter is fried my tach is waving at me all the time but its home and safe. Thanks for all your help
IP: Logged

next newest topic | next oldest topic

All times are ET (US)

Post New Topic  Post A Reply
Hop to:

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock