Pennock's Fiero Forum
  Technical Discussion & Questions - Archive
  Alternator ????

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Email This Page to Someone! | Printable Version


Alternator ???? by emsdad
Started on: 06-04-2008 08:40 AM
Replies: 3
Last post by: Synthesis on 06-04-2008 03:16 PM
emsdad
Member
Posts: 251
From: Va
Registered: Mar 2008


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-04-2008 08:40 AM Click Here to See the Profile for emsdadSend a Private Message to emsdadDirect Link to This Post
I have a 1986 2.5 w/ac and auto. My question is it seems like when the alternator is cycling to charge the the belt squeals. I think that is ccausing the erratic idle when sitting at stoplights also. I do not drive the car much at night but last ight I was out and with the headlights on it didn't seem like I could get the belt to stop squealing. When I turned the lights off everything was normal with no squealing. Could the alt. be bad? How hard are they to replce? It looks like a bear of a job.
IP: Logged
PFF
System Bot
Synthesis
Member
Posts: 12102
From: Jordan, MN
Registered: Feb 2002


Feedback score:    (19)
Leave feedback





Total ratings: 288
Rate this member

Report this Post06-04-2008 01:01 PM Click Here to See the Profile for SynthesisSend a Private Message to SynthesisDirect Link to This Post
Replace your alternator belt.

IP: Logged
emsdad
Member
Posts: 251
From: Va
Registered: Mar 2008


Feedback score: N/A
Leave feedback

Rate this member

Report this Post06-04-2008 03:09 PM Click Here to See the Profile for emsdadSend a Private Message to emsdadDirect Link to This Post
The belt is new. I put the good gates belt on a month ago. I adjustd the ension also.
IP: Logged
Synthesis
Member
Posts: 12102
From: Jordan, MN
Registered: Feb 2002


Feedback score:    (19)
Leave feedback





Total ratings: 288
Rate this member

Report this Post06-04-2008 03:16 PM Click Here to See the Profile for SynthesisSend a Private Message to SynthesisDirect Link to This Post
If the belt is new, tensioned correctly, and no issues with it otherwise, then you need to check your alternator bracket and make sure it is not cracked or bent.

The Duke has the steel bracket that runs overhead. I have seen those crack before. It throws the pulley out of alignment.

You can even pull the belt and try some sandpaper on the pulley to see if that helps.

Oh... Turn the alt pulley by hand without the belt. Does it spin freely or does it bind up at all?

If it binds up for any reason with no belt on it, yes. Change the alt. If it spins freely, then it is most likely good, and an alignment issue is causing the squeal.
IP: Logged



All times are ET (US)

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock