Pennock's Fiero Forum
  Technical Discussion & Questions - Archive
  Speedometer doesn't work

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Email This Page to Someone! | Printable Version


Speedometer doesn't work by NeoTristan
Started on: 05-04-2008 09:52 PM
Replies: 4
Last post by: NeoTristan on 05-06-2008 12:28 AM
NeoTristan
Member
Posts: 321
From: Macedonia/ Moncks Corner, SC
Registered: Sep 2007


Feedback score: N/A
Leave feedback

Rate this member

Report this Post05-04-2008 09:52 PM Click Here to See the Profile for NeoTristanClick Here to visit NeoTristan's HomePageClick Here to Email NeoTristanSend a Private Message to NeoTristanDirect Link to This Post
I just picked up a beater 86 SE and the speedometer/ odomenter doesn't work. Any suggestions?

------------------
Tristan
84 Fiero SE

IP: Logged
PFF
System Bot
jscott1
Member
Posts: 21674
From: Houston, TX , USA
Registered: Dec 2001


Feedback score:    (15)
Leave feedback





Total ratings: 415
Rate this member

Report this Post05-04-2008 10:35 PM Click Here to See the Profile for jscott1Send a Private Message to jscott1Direct Link to This Post
Going to need a bit more info. Check the obvious radio fuse, is there a VSS? Is it putting out anything? Check the plugs on the speedo, is it plugged in?
IP: Logged
NeoTristan
Member
Posts: 321
From: Macedonia/ Moncks Corner, SC
Registered: Sep 2007


Feedback score: N/A
Leave feedback

Rate this member

Report this Post05-04-2008 10:59 PM Click Here to See the Profile for NeoTristanClick Here to visit NeoTristan's HomePageClick Here to Email NeoTristanSend a Private Message to NeoTristanDirect Link to This Post
Well, I looked at all the fuses today and they are fine... there isn't a radio in the car right now but I do not see what its fuse has to do with the gauge... (you'll have to excuse me a bit, this is my first v6 and I still know very little about it as compared to the Duke). I guess I'll try to check connections.. if i can find them
IP: Logged
jscott1
Member
Posts: 21674
From: Houston, TX , USA
Registered: Dec 2001


Feedback score:    (15)
Leave feedback





Total ratings: 415
Rate this member

Report this Post05-04-2008 11:37 PM Click Here to See the Profile for jscott1Send a Private Message to jscott1Direct Link to This Post
The gauges and radio share the same fuse. There are many causes for a bad speedometer... Until you check a few things I am just guessing.
IP: Logged
NeoTristan
Member
Posts: 321
From: Macedonia/ Moncks Corner, SC
Registered: Sep 2007


Feedback score: N/A
Leave feedback

Rate this member

Report this Post05-06-2008 12:28 AM Click Here to See the Profile for NeoTristanClick Here to visit NeoTristan's HomePageClick Here to Email NeoTristanSend a Private Message to NeoTristanDirect Link to This Post
Ok, by the numbers what do I check. Here is all the info I have
86 SE V6
4-speed
All fuses are good.
IP: Logged



All times are ET (US)

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock