Pennock's Fiero Forum
  Technical Discussion & Questions - Archive
  Stock Automatic Problems.

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Email This Page to Someone! | Printable Version


Stock Automatic Problems. by 87FieroGT
Started on: 12-11-2007 02:03 PM
Replies: 4
Last post by: uhlanstan on 12-15-2007 07:27 PM
87FieroGT
Member
Posts: 490
From: Harlingen, TX, U.S.A.
Registered: May 99


Feedback score: (1)
Leave feedback

Rate this member

Report this Post12-11-2007 02:03 PM Click Here to See the Profile for 87FieroGTClick Here to Email 87FieroGTSend a Private Message to 87FieroGTDirect Link to This Post
I am having problems with my automatic transmission not running correctly. It shifts in out of gears erradictly. Could this be a Throttle position sensor problem? Is there a way to test the TPS so I know for sure that this is the problem? Let me know. Thanks.

------------------
----------------------

IP: Logged
PFF
System Bot
Cajun
Member
Posts: 1407
From: Youngsville, La., USA
Registered: Dec 2003


Feedback score: (1)
Leave feedback

Rate this member

Report this Post12-11-2007 02:30 PM Click Here to See the Profile for CajunClick Here to Email CajunSend a Private Message to CajunDirect Link to This Post

I know this is not the help you are seeking. But, a copy of the automatic transmission can be located at the following address.

http://spad.sytes.net/fiero/manuals/

Best of luck.
IP: Logged
Pyrthian
Member
Posts: 29541
From: Detroit, MI
Registered: Jul 2002


Feedback score: (5)
Leave feedback





Total ratings: 341
Rate this member

Report this Post12-11-2007 03:06 PM Click Here to See the Profile for PyrthianClick Here to Email PyrthianSend a Private Message to PyrthianDirect Link to This Post
nope. the TH125 auto trans in the Fieros has ZERO input from sensors (except for the torque convertor lockup).
what it does have is the "throttle valve" cable. it goes from the throttle body, around the front of the motor, then back to the middle of the top of the tranny. its a plastic sheathed cable, and can crack, and cause shifting issues like you are seeing.
IP: Logged
87GTBro
Member
Posts: 1223
From: Edinburg,TX,USA
Registered: Oct 1999


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-12-2007 02:02 PM Click Here to See the Profile for 87GTBroClick Here to Email 87GTBroSend a Private Message to 87GTBroDirect Link to This Post
 
quote
Originally posted by Cajun:


I know this is not the help you are seeking. But, a copy of the automatic transmission can be located at the following address.

http://spad.sytes.net/fiero/manuals/

Best of luck.


The transmission service manual really helped. The problem was the TV cable. I don't know how it lost adjustment, but adjusting it again solved the shifting problems.

Thanks!

------------------

IP: Logged
uhlanstan
Member
Posts: 6446
From: orlando florida
Registered: Apr 2007


Feedback score: N/A
Leave feedback





Total ratings: 427
User Banned

Report this Post12-15-2007 07:27 PM Click Here to See the Profile for uhlanstanClick Here to Email uhlanstanSend a Private Message to uhlanstanDirect Link to This Post
The tps can cause hunting,check for low or high readings..Closed below 1.25 volt WOT about 5 volt.. there was a recent post about this with photo of volt check..check for sticking Not sure if you solved the problem..,Hunting is normally caused by the governor assembly..also low fluid .Remember the T V cable must operate FREELY.also the shift linkage must operate freely,check it.If a proper ajustment of T V cable is made,and this does not remedy problem,, then suspect Governor assembly.. the spring or the wings! eyeball the spring and check the wings for ease of motion.this part is easily serviced by a person of moderate mechanical skill..Go slow as you disasemble the Governor,,be carefull of the speedo gear,,check for sticking parts..lay the parts out as you pull off..put in a box on clean rag.. the first suspect is always the fluid or filter.. a glogged filter or valve body could cause this, but this happens seldom,,first fluid,,next TV cable & shift mechanism,,next Governor....... the valve body is also easy to service, for valve body removal ,one of the bolts is not to be removed or removed last ,,can not remember.. ,the valve body is directly above the filter..An inproper operating engine(missing, stuttering) will also cause this ,but it would be obvious..If you have tps code let me know and I will post more info,, I could not access the spad site,beyond the first page,looks good for auto info..

[This message has been edited by uhlanstan (edited 12-17-2007).]

IP: Logged



All times are ET (US)

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock