Pennock's Fiero Forum
  Technical Discussion & Questions - Archive
  88 fuel tank baffle

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Email This Page to Someone! | Printable Version


88 fuel tank baffle by Azteca
Started on: 10-27-2007 09:42 AM
Replies: 0
Last post by: Azteca on 10-27-2007 09:42 AM
Azteca
Junior Member
Posts: 4
From: brick,new jersey,usa
Registered: Oct 2007


Feedback score: N/A
Leave feedback

Rate this member

Report this Post10-27-2007 09:42 AM Click Here to See the Profile for AztecaClick Here to Email AztecaSend a Private Message to AztecaDirect Link to This Post
Guys,in a nutshell,here's the problem,changed what I thought was a bad sending unit,got it from the f store,same problem,bad readings,etc.requested a new one,got it ,put it in,same problem,now i was told,check the baffle,if its broken,this is what happens,sure enough,i looked inside,cracked plstic,and I guess the design is to have the baffle ride the fill and vent tube.Well, I couldn"t get the whole baffle out,so I just jammed it forward,re-installed,worked for an hour,now it sounds like crap!Any correct fixes for this,or do I need to find another tank,hopefully with a good baffle,which at this point,is getting impossible to find.And why did they make a slidng baffle? Not a great idea from any point of view.thanks for any input!
IP: Logged
PFF
System Bot



All times are ET (US)

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock