Pennock's Fiero Forum
  Technical Discussion & Questions - Archive
  Posessed Car!

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Email This Page to Someone! | Printable Version


Posessed Car! by PineyCreek
Started on: 09-11-2007 12:09 PM
Replies: 2
Last post by: Oreif on 09-11-2007 12:21 PM
PineyCreek
Member
Posts: 459
From: Austin, TX USA
Registered: Sep 2007


Feedback score: (1)
Leave feedback

Rate this member

Report this Post09-11-2007 12:09 PM Click Here to See the Profile for PineyCreekClick Here to visit PineyCreek's HomePageSend a Private Message to PineyCreekDirect Link to This Post
My car is posessed. No other explanation. Well, maybe gremlins.

Oil pressure sender not working when the car was bought, fixed itself.
Speedometer wasn’t working last night…this morning it was. The overall mileage counter seems to work, but not the resettable counter (any guesses on this?).

You think if I just leave it alone it’ll “fix” the car to have a engine and transmission swap?

------------------
1986 SE V6, stock, auto. GT Trim and Body panels.

IP: Logged
PFF
System Bot
gem1138
Member
Posts: 631
From: Baton Rouge, LA
Registered: Aug 2007


Feedback score: N/A
Leave feedback

Rate this member

Report this Post09-11-2007 12:17 PM Click Here to See the Profile for gem1138Click Here to Email gem1138Send a Private Message to gem1138Direct Link to This Post
I just bought one with 30k on it and the only thing that doesn't work in the trip odometer. With the reflections in the clear panel though, it is all but impossible to read anyway. I drove the car 1k miles before I even saw it. I suspect that it is an common failure.
Funny about the gremlins. I'd look for a grounding problem. It's far more likely than waking up tomorrow to find a 4.9L magically in place.
IP: Logged
Oreif
Member
Posts: 16460
From: Schaumburg, IL
Registered: Jan 2000


Feedback score:    (19)
Leave feedback





Total ratings: 442
Rate this member

Report this Post09-11-2007 12:21 PM Click Here to See the Profile for OreifClick Here to visit Oreif's HomePageClick Here to Email OreifSend a Private Message to OreifDirect Link to This Post
 
quote
Originally posted by PineyCreek:

You think if I just leave it alone it’ll “fix” the car to have a engine and transmission swap?



Did you buy it from an old guy who said it was his brothers car but his brother passed away?
Does the odometer seem to run backwards occassionally?
Is the car nicknamed "Christine"?

If the answers are "No", It won't fix itself.



Anyhow the trip odometer sometimes doesn't reset the gear correctly and it won't work. Try resetting it a few times and see if it catches. If not you can clean the gear shaft and it will work fine. The oil pressure sender has a small hole that if there is dirt in the oil, can clog causing intermittent or inaccurate readings. The flex-print that goes on the rear of the gauge panel could have some dirty connections affecting the speedo. You can buy electrical contact cleaner at an electronics store and clean the contacts (could also be related to the oil gauge if it is in the same cluster.)

------------------

Happiness isn't around the corner...
Happiness IS the corner.

ZZ4 Powered !!

[This message has been edited by Oreif (edited 09-11-2007).]

IP: Logged



All times are ET (US)

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock