Pennock's Fiero Forum
  Technical Discussion & Questions - Archive
  Crunch on hard accelleration?

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Email This Page to Someone! | Printable Version


Crunch on hard accelleration? by InDeX420
Started on: 03-23-2004 09:02 PM
Replies: 5
Last post by: InDeX420 on 03-24-2004 07:04 PM
InDeX420
Member
Posts: 567
From: New MILF-ord, CT
Registered: Dec 2003


Feedback score: N/A
Leave feedback

Rate this member

Report this Post03-23-2004 09:02 PM Click Here to See the Profile for InDeX420Click Here to visit InDeX420's HomePageSend a Private Message to InDeX420Direct Link to This Post
My 88 Formula with 5spd has been making a crunching noise if i accellerate hard from a stop or a near stop...it seems to happen when the wheels slip, especially around a turn...It feels as if the car grabs and goes grabs and goes and all the while i here crunch crunch noise...it car only has about 45k miles on it..could this be some prob with the tranny?? or a mount maybe?? Any help would be appreciated
Thanks in advance..
IP: Logged
PFF
System Bot
ryan.hess
Member
Posts: 20784
From: Orlando, FL
Registered: Dec 2002


Feedback score: (1)
Leave feedback





Total ratings: 319
Rate this member

Report this Post03-23-2004 09:05 PM Click Here to See the Profile for ryan.hessClick Here to Email ryan.hessSend a Private Message to ryan.hessDirect Link to This Post
could be bad CV joints... Check your boots for damage. Also maybe a bad dogbone/tranny/engine mounts...
IP: Logged
avengador1
Member
Posts: 35467
From: Orlando, Florida
Registered: Oct 2001


Feedback score:    (7)
Leave feedback





Total ratings: 572
Rate this member

Report this Post03-23-2004 09:06 PM Click Here to See the Profile for avengador1Click Here to Email avengador1Send a Private Message to avengador1Direct Link to This Post
It sounds like it could be a bad CV joint. Does it do it when you are turning and does it do it in one direction more than the other?
IP: Logged
InDeX420
Member
Posts: 567
From: New MILF-ord, CT
Registered: Dec 2003


Feedback score: N/A
Leave feedback

Rate this member

Report this Post03-23-2004 09:55 PM Click Here to See the Profile for InDeX420Click Here to visit InDeX420's HomePageSend a Private Message to InDeX420Direct Link to This Post
Ive checked the CV boots they are fine...it seems different from a cv type clunk or clicking...i cant explain the sound better then a crunch-chrunch-crunch... Ill have to check the mounts then...
IP: Logged
Dropzone
Member
Posts: 185
From: Fayetteville, NC
Registered: Oct 2003


Feedback score: N/A
Leave feedback

Rate this member

Report this Post03-24-2004 07:31 AM Click Here to See the Profile for DropzoneClick Here to Email DropzoneSend a Private Message to DropzoneDirect Link to This Post
What about your upper strut mounts? The mounts on my Beretta are popping when I back up and have a 'slapping' sound when I'm on rough roads. Think this might be your problem?

------------------
-jason
'87SE
'88GT (5spd)
'90GTZ

IP: Logged
InDeX420
Member
Posts: 567
From: New MILF-ord, CT
Registered: Dec 2003


Feedback score: N/A
Leave feedback

Rate this member

Report this Post03-24-2004 07:04 PM Click Here to See the Profile for InDeX420Click Here to visit InDeX420's HomePageSend a Private Message to InDeX420Direct Link to This Post
Im going to have to try and record it....i cant explain it very well..
Fieros dont suffer from wheel hop right??? It almost feels like that..but a crunch each time that it pulls....
.doesnt really matter anymore since im takin her off the road....just in time for summer too but its about time i had a V8 fiero....
IP: Logged



All times are ET (US)

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock