Pennock's Fiero Forum
  Technical Discussion & Questions - Archive
  Tach stopped working.

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Email This Page to Someone! | Printable Version


Tach stopped working. by manual63
Started on: 12-28-2003 02:29 PM
Replies: 3
Last post by: manual63 on 12-29-2003 08:58 AM
manual63
Member
Posts: 29
From: Edina, MN USA
Registered: Dec 2003


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-28-2003 02:29 PM Click Here to See the Profile for manual63Click Here to visit manual63's HomePageClick Here to Email manual63Send a Private Message to manual63Direct Link to This Post
I have an '84 with the 2.5 L I4. The Tach stopped working and I was wondering if anyone might know where I should check. I am assuming a cable came loose or something, but am not entirely sure.

Thanks.

Oh, it's an automatic....

------------------

[This message has been edited by manual63 (edited 12-28-2003).]

IP: Logged
PFF
System Bot
Whuffo
Member
Posts: 3000
From: San Jose, CA
Registered: Jul 2003


Feedback score: N/A
Leave feedback





Total ratings: 154
Rate this member

Report this Post12-28-2003 02:35 PM Click Here to See the Profile for WhuffoClick Here to visit Whuffo's HomePageClick Here to Email WhuffoSend a Private Message to WhuffoDirect Link to This Post
 
quote
Originally posted by manual63:

I have an '84 with the 2.5 L I4. The Tach stopped working and I was wondering if anyone might know where I should check. I am assuming a cable came loose or something, but am not entirely sure.

Thanks.

Most likely you have a bad tach filter - it's a aluminum cylinder about 5/8" in diameter and 7/8" long and it's usually mounted to the ignition coil bracket. If you can find one in the boneyard it might be OK - this part is no longer available from GM. Rodney Dickman also has a custom made replacement for this part - you can find it here:

http://www.rodneydickman.com/n27.html

IP: Logged
454Fiero
Member
Posts: 170
From:
Registered: Nov 2003


Feedback score: N/A
Leave feedback





Total ratings: 58
Rate this member

Report this Post12-28-2003 05:45 PM Click Here to See the Profile for 454FieroSend a Private Message to 454FieroDirect Link to This Post
'

[This message has been edited by 454Fiero (edited 04-12-2004).]

IP: Logged
manual63
Member
Posts: 29
From: Edina, MN USA
Registered: Dec 2003


Feedback score: N/A
Leave feedback

Rate this member

Report this Post12-29-2003 08:58 AM Click Here to See the Profile for manual63Click Here to visit manual63's HomePageClick Here to Email manual63Send a Private Message to manual63Direct Link to This Post
Thanks.

Well, I have dash work to do anyway. So while I am in there I will look into the Corrosion thing on the guages. I have had my Fiero for a week and 1/2 now and have already ordered 1 part from Rodney Dickman's (fast service) and will be ordering another in the next day or two. I wish I knew all that I needed so I can just order it all......like maybe a whole new rebuilt Fiero....LOL....

------------------

IP: Logged



All times are ET (US)

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock