Pennock's Fiero Forum
  Technical Discussion & Questions - Archive
  Jumpy tach and engine surge at 70 mph

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Email This Page to Someone! | Printable Version


Jumpy tach and engine surge at 70 mph by js
Started on: 11-14-2003 10:27 PM
Replies: 1
Last post by: avengador1 on 11-15-2003 08:48 AM
js
Member
Posts: 59
From: Wales, WI
Registered: Dec 1999


Feedback score: N/A
Leave feedback

Rate this member

Report this Post11-14-2003 10:27 PM Click Here to See the Profile for jsClick Here to Email jsSend a Private Message to jsDirect Link to This Post
I am having an occaissonal jumpy tach reading and at the same time a slight engine surge at about 70 mpm freeway speed in my '86 2.8L. Radio noise too. I remember having this a few years ago and I thought changing the spark plug wires fixed it. I changed them yesterday and I still get the same behavior. I thought it might be the tach filter, but would that affect engine performance?
How can I fix this?

Thanks in advance

IP: Logged
PFF
System Bot
avengador1
Member
Posts: 35467
From: Orlando, Florida
Registered: Oct 2001


Feedback score:    (7)
Leave feedback





Total ratings: 572
Rate this member

Report this Post11-15-2003 08:48 AM Click Here to See the Profile for avengador1Click Here to Email avengador1Send a Private Message to avengador1Direct Link to This Post
Going by your clues of radio noise and engine surge, I would suspect some sort of high voltage leak. Check your spark plug wires at night and see if you get a light show, especially near the spark plug boots. If you do see the sparks flying it's time for new wires.
IP: Logged



All times are ET (US)

T H I S   I S   A N   A R C H I V E D   T O P I C
  

Contact Us | Back To Main Page

Advertizing on PFF | Fiero Parts Vendors
PFF Merchandise | Fiero Gallery | Ogre's Cave
Real-Time Chat | Fiero Related Auctions on eBay



Copyright (c) 1999, C. Pennock